Revert "openthread-br: fix actually building"

This reverts commit 5958fd068f.
This commit is contained in:
Stijn Tintel 2023-09-30 06:04:55 +03:00
parent 219b7d457e
commit c9b6c36478
2 changed files with 12 additions and 4 deletions

View file

@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openthread-br PKG_NAME:=openthread-br
PKG_SOURCE_DATE:=2023-08-01 PKG_SOURCE_DATE:=2023-08-01
PKG_SOURCE_VERSION:=1738d8cd8b42106c2ef1262fbbac2f06beab83ba PKG_SOURCE_VERSION:=1738d8cd8b42106c2ef1262fbbac2f06beab83ba
PKG_RELEASE:=2 PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=https://github.com/openthread/ot-br-posix.git PKG_SOURCE_URL=https://github.com/openthread/ot-br-posix.git
@ -74,9 +74,7 @@ CMAKE_OPTIONS += \
-DOTBR_SRP_SERVER_AUTO_ENABLE:BOOL=ON \ -DOTBR_SRP_SERVER_AUTO_ENABLE:BOOL=ON \
-DOTBR_TREL:BOOL=ON -DOTBR_TREL:BOOL=ON
TARGET_CFLAGS += -DOPENTHREAD_POSIX_CONFIG_DAEMON_SOCKET_BASENAME=\\\"/var/run/openthread-%s\\\" \ TARGET_CFLAGS += -DOPENTHREAD_POSIX_CONFIG_DAEMON_SOCKET_BASENAME=\\\"/var/run/openthread-%s\\\"
-I$(STAGING_DIR)/usr/include/mdns \
-L$(STAGING_DIR)/usr/lib/mdns
define Package/luci-app-openthread/install define Package/luci-app-openthread/install
$(INSTALL_DIR) \ $(INSTALL_DIR) \
@ -96,6 +94,7 @@ endef
define Package/openthread-br/install define Package/openthread-br/install
$(INSTALL_DIR) \ $(INSTALL_DIR) \
$(1)/etc/init.d \
$(1)/lib/netifd/proto \ $(1)/lib/netifd/proto \
$(1)/usr/sbin \ $(1)/usr/sbin \
$(1)/var/lib/thread $(1)/var/lib/thread

View file

@ -16,6 +16,8 @@ otDatasetCreateNewNetwork).
src/rest/resource.hpp | 1 + src/rest/resource.hpp | 1 +
3 files changed, 57 insertions(+) 3 files changed, 57 insertions(+)
diff --git a/src/rest/openapi.yaml b/src/rest/openapi.yaml
index 2ba2a4dd56..2edc4af29a 100644
--- a/src/rest/openapi.yaml --- a/src/rest/openapi.yaml
+++ b/src/rest/openapi.yaml +++ b/src/rest/openapi.yaml
@@ -248,6 +248,18 @@ paths: @@ -248,6 +248,18 @@ paths:
@ -53,6 +55,8 @@ otDatasetCreateNewNetwork).
components: components:
schemas: schemas:
LeaderData: LeaderData:
diff --git a/src/rest/resource.cpp b/src/rest/resource.cpp
index a60e9d9483..829835341a 100644
--- a/src/rest/resource.cpp --- a/src/rest/resource.cpp
+++ b/src/rest/resource.cpp +++ b/src/rest/resource.cpp
@@ -767,12 +767,47 @@ exit: @@ -767,12 +767,47 @@ exit:
@ -103,6 +107,8 @@ otDatasetCreateNewNetwork).
case HttpMethod::kGet: case HttpMethod::kGet:
GetDataset(aDatasetType, aRequest, aResponse); GetDataset(aDatasetType, aRequest, aResponse);
break; break;
diff --git a/src/rest/resource.hpp b/src/rest/resource.hpp
index d79085dbfc..362e501471 100644
--- a/src/rest/resource.hpp --- a/src/rest/resource.hpp
+++ b/src/rest/resource.hpp +++ b/src/rest/resource.hpp
@@ -150,6 +150,7 @@ private: @@ -150,6 +150,7 @@ private:
@ -113,3 +119,6 @@ otDatasetCreateNewNetwork).
void DeleteOutDatedDiagnostic(void); void DeleteOutDatedDiagnostic(void);
void UpdateDiag(std::string aKey, std::vector<otNetworkDiagTlv> &aDiag); void UpdateDiag(std::string aKey, std::vector<otNetworkDiagTlv> &aDiag);
--
2.41.0