acl: add ACL tools and libs
Signed-off-by: Maxim Storchak <m.storchak@gmail.com>
This commit is contained in:
parent
bbf5f89801
commit
c9b56fef35
4 changed files with 141 additions and 0 deletions
98
utils/acl/Makefile
Normal file
98
utils/acl/Makefile
Normal file
|
@ -0,0 +1,98 @@
|
||||||
|
#
|
||||||
|
# Copyright (C) 2014 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=acl
|
||||||
|
PKG_REV:=f2a5f57a20ffa007abc1fa24df1f76e18b74a425
|
||||||
|
PKG_VERSION:=20140610
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=git://git.sv.gnu.org/acl.git
|
||||||
|
PKG_SOURCE_PROTO:=git
|
||||||
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/acl/Default
|
||||||
|
TITLE:=Access control list (ACL) manipulation
|
||||||
|
URL:=http://savannah.nongnu.org/projects/acl
|
||||||
|
SUBMENU:=Filesystem
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/acl/Default/description
|
||||||
|
Access control list support
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/acl
|
||||||
|
$(call Package/acl/Default)
|
||||||
|
SECTION:=utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
TITLE+=utils
|
||||||
|
DEPENDS:=+libacl
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/libacl
|
||||||
|
$(call Package/acl/Default)
|
||||||
|
SECTION:=libs
|
||||||
|
CATEGORY:=Libraries
|
||||||
|
TITLE+=library
|
||||||
|
DEPENDS:=+libattr
|
||||||
|
KCONFIG:= \
|
||||||
|
CONFIG_EXT4_FS_POSIX_ACL=y \
|
||||||
|
CONFIG_FS_POSIX_ACL=y \
|
||||||
|
CONFIG_HFSPLUS_FS_POSIX_ACL=y \
|
||||||
|
CONFIG_JFFS2_FS_POSIX_ACL=y \
|
||||||
|
CONFIG_JFS_POSIX_ACL=y \
|
||||||
|
CONFIG_TMPFS_POSIX_ACL=y \
|
||||||
|
CONFIG_XFS_POSIX_ACL=y \
|
||||||
|
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/libacl/description
|
||||||
|
$(call Package/acl/Default/description)
|
||||||
|
This package provides libacl
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/acl/description
|
||||||
|
$(call Package/acl/Default/description)
|
||||||
|
This package provides ACL manipulation utilities
|
||||||
|
- chacl
|
||||||
|
- getfacl
|
||||||
|
- setfacl
|
||||||
|
endef
|
||||||
|
|
||||||
|
CONFIGURE_ARGS += --enable-static --enable-shared
|
||||||
|
|
||||||
|
define Build/Prepare
|
||||||
|
$(call Build/Prepare/Default)
|
||||||
|
(cd $(PKG_BUILD_DIR); ./autogen.sh;);
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/acl/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/libacl/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/InstallDev
|
||||||
|
mkdir -p $(1)/usr/include
|
||||||
|
mkdir -p $(1)/usr/lib/pkgconfig
|
||||||
|
$(CP) -r $(PKG_INSTALL_DIR)/usr/{include,lib} $(1)/usr/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,acl))
|
||||||
|
$(eval $(call BuildPackage,libacl))
|
21
utils/acl/patches/100-no-gettext_configure.patch
Normal file
21
utils/acl/patches/100-no-gettext_configure.patch
Normal file
|
@ -0,0 +1,21 @@
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 2182e81..4836b3d 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -31,9 +31,6 @@ AC_FUNC_GCC_VISIBILITY
|
||||||
|
AM_PROG_AR
|
||||||
|
LT_INIT
|
||||||
|
|
||||||
|
-AM_GNU_GETTEXT_VERSION([0.18.2])
|
||||||
|
-AM_GNU_GETTEXT([external])
|
||||||
|
-
|
||||||
|
AC_ARG_ENABLE([debug],
|
||||||
|
[AS_HELP_STRING([--enable-debug], [Enable extra debugging])])
|
||||||
|
AS_IF([test "x$enable_debug" = "xyes"],
|
||||||
|
@@ -61,6 +58,5 @@ AC_CONFIG_COMMANDS([include/sys],
|
||||||
|
AC_CONFIG_FILES([
|
||||||
|
libacl.pc
|
||||||
|
Makefile
|
||||||
|
- po/Makefile.in
|
||||||
|
])
|
||||||
|
AC_OUTPUT
|
9
utils/acl/patches/101-no-gettext_autogen.patch
Normal file
9
utils/acl/patches/101-no-gettext_autogen.patch
Normal file
|
@ -0,0 +1,9 @@
|
||||||
|
diff --git a/autogen.sh b/autogen.sh
|
||||||
|
index a98a3c5..982aff1 100755
|
||||||
|
--- a/autogen.sh
|
||||||
|
+++ b/autogen.sh
|
||||||
|
@@ -1,4 +1,2 @@
|
||||||
|
#!/bin/sh -ex
|
||||||
|
-po/update-potfiles
|
||||||
|
-autopoint --force
|
||||||
|
exec autoreconf -f -i
|
13
utils/acl/patches/102-no-gettext_Makefile.patch
Normal file
13
utils/acl/patches/102-no-gettext_Makefile.patch
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
diff --git a/Makefile.am b/Makefile.am
|
||||||
|
index 47d2a4e..d02ee91 100644
|
||||||
|
--- a/Makefile.am
|
||||||
|
+++ b/Makefile.am
|
||||||
|
@@ -3,8 +3,6 @@ ACLOCAL_AMFLAGS = -I m4
|
||||||
|
EXTRA_DIST = \
|
||||||
|
exports
|
||||||
|
|
||||||
|
-SUBDIRS = po
|
||||||
|
-
|
||||||
|
AM_CPPFLAGS = \
|
||||||
|
-I$(top_builddir)/include \
|
||||||
|
-I$(top_srcdir)/include \
|
Loading…
Reference in a new issue