node-*: node update to v4.4.4
This commit is contained in:
parent
2339a827c2
commit
c9115cdf54
6 changed files with 19 additions and 2483 deletions
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||
PKG_NPM_NAME:=arduino-firmata
|
||||
PKG_NAME:=node-$(PKG_NPM_NAME)
|
||||
PKG_VERSION:=0.3.3
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/shokai/node-arduino-firmata.git
|
||||
|
@ -19,7 +19,7 @@ PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_SOURCE_VERSION)
|
|||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
|
||||
PKG_BUILD_DEPENDS:=node/host
|
||||
PKG_NODE_VERSION:=0.12.13
|
||||
PKG_NODE_VERSION:=4.4.4
|
||||
|
||||
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
|
||||
PKG_LICENSE:=MIT
|
||||
|
|
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||
PKG_NPM_NAME:=cylon
|
||||
PKG_NAME:=node-$(PKG_NPM_NAME)
|
||||
PKG_VERSION:=0.22.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/hybridgroup/cylon-firmata.git
|
||||
|
@ -19,7 +19,7 @@ PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_SOURCE_VERSION)
|
|||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
|
||||
PKG_BUILD_DEPENDS:=node/host
|
||||
PKG_NODE_VERSION:=0.12.13
|
||||
PKG_NODE_VERSION:=4.4.4
|
||||
|
||||
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
|
|
|
@ -9,17 +9,17 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NPM_NAME:=hid
|
||||
PKG_NAME:=node-$(PKG_NPM_NAME)
|
||||
PKG_VERSION:=0.4.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.5.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/node-hid/node-hid.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=c56c8aa5d113c6f2574d1f7e64d41745702965bb
|
||||
PKG_SOURCE_VERSION:=35d830b7810c87d32484d0a346621568c4849441
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
|
||||
PKG_BUILD_DEPENDS:=node/host
|
||||
PKG_NODE_VERSION:=0.12.13
|
||||
PKG_NODE_VERSION:=4.4.4
|
||||
|
||||
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
|
||||
PKG_LICENSE:=Custom
|
||||
|
@ -41,6 +41,8 @@ define Package/node-hid/description
|
|||
Node.js package to access HID devices
|
||||
endef
|
||||
|
||||
CPU:=$(subst x86_64,x64,$(subst i386,ia32,$(ARCH)))
|
||||
|
||||
EXTRA_LDFLAGS+="-lhidapi-libusb"
|
||||
EXTRA_CFLAGS+="-I$(STAGING_DIR)/usr/include/hidapi/"
|
||||
|
||||
|
@ -51,12 +53,12 @@ define Build/Compile
|
|||
npm_config_nodedir=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/ \
|
||||
npm_config_cache=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/npm-cache \
|
||||
PREFIX="$(PKG_INSTALL_DIR)/usr/" \
|
||||
$(STAGING_DIR)/host/bin/npm install -g $(PKG_BUILD_DIR)
|
||||
$(STAGING_DIR)/host/bin/npm install --build-from-source --target_arch=$(CPU) -g $(PKG_BUILD_DIR)
|
||||
endef
|
||||
|
||||
define Package/node-hid/install
|
||||
mkdir -p $(1)/usr/lib/node/node-hid/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/node_modules/node-hid/{index.js,package.json,build,node_modules} $(1)/usr/lib/node/node-hid/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/node_modules/* $(1)/usr/lib/node/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,node-hid))
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -9,15 +9,15 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NPM_NAME:=serialport
|
||||
PKG_NAME:=node-$(PKG_NPM_NAME)
|
||||
PKG_VERSION:=1.4.6
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=3.0.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NPM_NAME)-$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=http://registry.npmjs.org/$(PKG_NPM_NAME)/-/
|
||||
PKG_MD5SUM:=1eb21082e0aa676b8350182a60230808
|
||||
PKG_MD5SUM:=ea20a17746dd64e72d5f6f2019d9e28d
|
||||
|
||||
PKG_BUILD_DEPENDS:=node/host
|
||||
PKG_NODE_VERSION:=0.12.13
|
||||
PKG_NODE_VERSION:=4.4.4
|
||||
|
||||
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
|
||||
PKG_LICENSE:=Custom
|
||||
|
@ -43,6 +43,8 @@ define Build/Prepare
|
|||
$(Build/Patch)
|
||||
endef
|
||||
|
||||
CPU:=$(subst x86_64,x64,$(subst i386,ia32,$(ARCH)))
|
||||
|
||||
EXTRA_LDFLAGS="-L$(TOOLCHAIN_DIR)/lib/ -Wl,-rpath-link $(TOOLCHAIN_DIR)/lib/" \
|
||||
|
||||
define Build/Compile
|
||||
|
@ -51,7 +53,7 @@ define Build/Compile
|
|||
npm_config_nodedir=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/ \
|
||||
npm_config_cache=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/npm-cache \
|
||||
PREFIX="$(PKG_INSTALL_DIR)/usr/" \
|
||||
$(STAGING_DIR)/host/bin/npm install -g $(PKG_BUILD_DIR)
|
||||
$(STAGING_DIR)/host/bin/npm install --build-from-source --target_arch=$(CPU) -g $(PKG_BUILD_DIR)
|
||||
endef
|
||||
|
||||
define Package/node-serialport/install
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- a/package.json 2014-05-02 12:02:02.940515727 +0200
|
||||
+++ b/package.json 2014-05-02 12:03:08.488512762 +0200
|
||||
@@ -69,7 +71,7 @@
|
||||
"serialportterm": "./bin/serialportTerminal.js"
|
||||
},
|
||||
"scripts": {
|
||||
- "install": "node-pre-gyp install --fallback-to-build",
|
||||
+ "install": "node-pre-gyp reinstall --build-from-source --target_arch=${npm_config_arch}",
|
||||
"test": "grunt --verbose"
|
||||
}
|
||||
}
|
Loading…
Reference in a new issue