ruby: rdoc can run without gems (with patch)
rdoc seems to be written to run without gem. However, some internal code still does not check for gems presence. With a small patch, rdoc can run without gems. Ref: https://bugs.ruby-lang.org/issues/10196 Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
This commit is contained in:
parent
a0e65256e9
commit
c90a4cb178
2 changed files with 33 additions and 1 deletions
|
@ -16,7 +16,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=ruby
|
||||
PKG_VERSION:=2.1.2
|
||||
PKG_RELEASE:=4
|
||||
PKG_RELEASE:=5
|
||||
|
||||
PKG_LIBVER:=2.1
|
||||
|
||||
|
|
32
lang/ruby/patches/001-rdoc-remove_gems_dep.patch
Normal file
32
lang/ruby/patches/001-rdoc-remove_gems_dep.patch
Normal file
|
@ -0,0 +1,32 @@
|
|||
--- ruby-2.1.2.orig/lib/rdoc.rb 2014-09-02 17:14:28.719224215 -0300
|
||||
+++ ruby-2.1.2/lib/rdoc.rb 2014-09-02 17:14:28.762223911 -0300
|
||||
@@ -109,6 +109,8 @@
|
||||
def self.load_yaml
|
||||
begin
|
||||
gem 'psych'
|
||||
+ rescue NameError => e # --disable-gems
|
||||
+ raise unless e.name == :gem
|
||||
rescue Gem::LoadError
|
||||
end
|
||||
|
||||
--- ruby-2.1.2.orig/lib/rdoc/markdown.rb 2014-09-02 17:14:28.761223918 -0300
|
||||
+++ ruby-2.1.2/lib/rdoc/markdown.rb 2014-09-02 17:14:28.805223607 -0300
|
||||
@@ -525,7 +525,6 @@
|
||||
|
||||
|
||||
|
||||
- require 'rubygems'
|
||||
require 'rdoc'
|
||||
require 'rdoc/markup/to_joined_paragraph'
|
||||
require 'rdoc/markdown/entities'
|
||||
--- ruby-2.1.2.orig/lib/rdoc/text.rb 2014-09-02 17:14:28.721224201 -0300
|
||||
+++ ruby-2.1.2/lib/rdoc/text.rb 2014-09-02 17:14:28.764223897 -0300
|
||||
@@ -10,6 +10,8 @@
|
||||
|
||||
begin
|
||||
gem 'json'
|
||||
+rescue NameError => e # --disable-gems
|
||||
+ raise unless e.name == :gem
|
||||
rescue Gem::LoadError
|
||||
end
|
||||
|
Loading…
Reference in a new issue