From c86ccd6512f00be67ebe2c8a0d80cdb62b1abcd2 Mon Sep 17 00:00:00 2001
From: Rosen Penev <rosenp@gmail.com>
Date: Sun, 7 Oct 2018 14:54:07 -0700
Subject: [PATCH] Werkzeug: Update to 0.14.1

Switched URL to a sensible one.

Some Makefile rearrangements for consistency.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
 lang/python/Werkzeug/Makefile | 13 +++++++------
 1 file changed, 7 insertions(+), 6 deletions(-)

diff --git a/lang/python/Werkzeug/Makefile b/lang/python/Werkzeug/Makefile
index 0f4a51a1e..0ed2d976a 100644
--- a/lang/python/Werkzeug/Makefile
+++ b/lang/python/Werkzeug/Makefile
@@ -5,17 +5,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=Werkzeug
-PKG_VERSION:=0.12.2
+PKG_VERSION:=0.14.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://pypi.python.org/packages/56/41/c095a77eb2dd69bf278dd664a97d3416af04e9ba1a00b8c138f772741d31/
-PKG_HASH:=903a7b87b74635244548b30d30db4c8947fe64c5198f58899ddcd3a13c23bb26
-PKG_BUILD_DEPENDS:=python python3
+PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/W/Werkzeug
+PKG_HASH:=c3fd7a7d41976d9f44db327260e263132466836cef6f91512889ed60ad26557c
+
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
-PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 
+PKG_BUILD_DEPENDS:=python python3
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-$(PKG_NAME)-$(PKG_VERSION)
 PKG_UNPACK=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
 
@@ -26,7 +27,7 @@ define Package/python3-werkzeug
   SECTION:=lang
   CATEGORY:=Languages
   SUBMENU:=Python
-  URL:=http://werkzeug.pocoo.org/
+  URL:=https://palletsprojects.com/p/werkzeug/
   TITLE:=python3-werkzeug
   DEPENDS:=+python3-light +python3-email
   VARIANT:=python3