python3: Update to 3.9.10, refresh patches
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
This commit is contained in:
parent
b9bfe1ef15
commit
c7f25b25df
7 changed files with 10 additions and 21 deletions
|
@ -8,7 +8,7 @@
|
|||
# Note: keep in sync with setuptools & pip
|
||||
PYTHON3_VERSION_MAJOR:=3
|
||||
PYTHON3_VERSION_MINOR:=9
|
||||
PYTHON3_VERSION_MICRO:=9
|
||||
PYTHON3_VERSION_MICRO:=10
|
||||
|
||||
PYTHON3_VERSION:=$(PYTHON3_VERSION_MAJOR).$(PYTHON3_VERSION_MINOR)
|
||||
|
||||
|
|
|
@ -16,8 +16,7 @@ PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
|
|||
|
||||
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
|
||||
# FIXME: if updating, get rid of [1] & [2] asap
|
||||
PKG_HASH:=06828c04a573c073a4e51c4292a27c1be4ae26621c3edc7cf9318418ce3b6d27
|
||||
PKG_HASH:=0a8fbfb5287ebc3a13e9baf3d54e08fa06778ffeccf6311aef821bb3a6586cc8
|
||||
|
||||
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
|
||||
PKG_LICENSE:=Python/2.0
|
||||
|
@ -207,14 +206,6 @@ define Build/Compile/python3-pip
|
|||
--root=$(PKG_BUILD_DIR)/install-pip \
|
||||
--prefix=/usr \
|
||||
$(PKG_BUILD_DIR)/Lib/ensurepip/_bundled/pip-$(PYTHON3_PIP_VERSION)-py3-none-any.whl
|
||||
# FIXME: [1] get rid of this asap; 'patch' doesn't like Windows endings, and this file is full of them...
|
||||
# I actually tried this in a number of ways and the only way to fix this is to implement
|
||||
# a poor-man's dos2unix using sed.
|
||||
# The issue is with the pip package; it seems that it throws in some Windows line-endings
|
||||
# and 'patch' won't handle them. So, we do a "dos2unix" and then patch.
|
||||
# We can get rid of this once this is solved upstream and in pip:
|
||||
# https://github.com/pypa/pep517/pull/130
|
||||
sed 's/\r//' -i $(PKG_BUILD_DIR)/install-pip/usr/lib/python$(PYTHON3_VERSION)/site-packages/pip/_vendor/pep517/in_process/__init__.py
|
||||
$(call PatchDir,$(PKG_BUILD_DIR)/install-pip/usr/lib/python$(PYTHON3_VERSION)/site-packages,./patches-pip,)
|
||||
endef
|
||||
else
|
||||
|
@ -373,8 +364,6 @@ define Host/Install
|
|||
touch $(HOST_PYTHON3_PKG_DIR)/.setuptools_installed_$(PYTHON3_SETUPTOOLS_VERSION)-$(PYTHON3_SETUPTOOLS_PKG_RELEASE)
|
||||
)
|
||||
$(if $(wildcard $(HOST_PYTHON3_PKG_DIR)/.pip_installed_$(PYTHON3_PIP_VERSION)-$(PYTHON3_PIP_PKG_RELEASE)),,
|
||||
# FIXME: [2] get rid of this asap; same as [1]
|
||||
sed 's/\r//' -i $(HOST_PYTHON3_PKG_DIR)/pip/_vendor/pep517/in_process/__init__.py
|
||||
$(call HostPatchDir,$(HOST_PYTHON3_PKG_DIR),./patches-pip,)
|
||||
touch $(HOST_PYTHON3_PKG_DIR)/.pip_installed_$(PYTHON3_PIP_VERSION)-$(PYTHON3_PIP_PKG_RELEASE)
|
||||
)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -737,7 +737,8 @@ class PyBuildExt(build_ext):
|
||||
@@ -740,7 +740,8 @@ class PyBuildExt(build_ext):
|
||||
# only change this for cross builds for 3.3, issues on Mageia
|
||||
if CROSS_COMPILING:
|
||||
self.add_cross_compiling_paths()
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -714,8 +714,9 @@ class PyBuildExt(build_ext):
|
||||
@@ -717,8 +717,9 @@ class PyBuildExt(build_ext):
|
||||
# directly since an inconsistently reproducible issue comes up where
|
||||
# the environment variable is not set even though the value were passed
|
||||
# into configure and stored in the Makefile (issue found on OS X 10.3).
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -15461,7 +15461,7 @@ $as_echo_n "checking ABIFLAGS... " >&6;
|
||||
@@ -15464,7 +15464,7 @@ $as_echo_n "checking ABIFLAGS... " >&6;
|
||||
$as_echo "$ABIFLAGS" >&6; }
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking SOABI" >&5
|
||||
$as_echo_n "checking SOABI... " >&6; }
|
||||
|
@ -11,7 +11,7 @@
|
|||
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4807,7 +4807,7 @@ AC_SUBST(SOABI)
|
||||
@@ -4812,7 +4812,7 @@ AC_SUBST(SOABI)
|
||||
AC_MSG_CHECKING(ABIFLAGS)
|
||||
AC_MSG_RESULT($ABIFLAGS)
|
||||
AC_MSG_CHECKING(SOABI)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -521,6 +521,7 @@ class PyBuildExt(build_ext):
|
||||
@@ -526,6 +526,7 @@ class PyBuildExt(build_ext):
|
||||
print("Failed to build these modules:")
|
||||
print_three_column(failed)
|
||||
print()
|
||||
|
|
|
@ -40,7 +40,7 @@
|
|||
# Here are a couple of targets for MacOSX again, to install a full
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -2979,7 +2979,7 @@ $as_echo_n "checking for python interpre
|
||||
@@ -2991,7 +2991,7 @@ $as_echo_n "checking for python interpre
|
||||
fi
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $interp" >&5
|
||||
$as_echo "$interp" >&6; }
|
||||
|
@ -49,7 +49,7 @@
|
|||
fi
|
||||
elif test "$cross_compiling" = maybe; then
|
||||
as_fn_error $? "Cross compiling required --host=HOST-TUPLE and --build=ARCH" "$LINENO" 5
|
||||
@@ -15531,7 +15531,7 @@ fi
|
||||
@@ -15534,7 +15534,7 @@ fi
|
||||
|
||||
|
||||
|
||||
|
@ -69,7 +69,7 @@
|
|||
fi
|
||||
elif test "$cross_compiling" = maybe; then
|
||||
AC_MSG_ERROR([Cross compiling required --host=HOST-TUPLE and --build=ARCH])
|
||||
@@ -4865,7 +4865,7 @@ fi],
|
||||
@@ -4870,7 +4870,7 @@ fi],
|
||||
|
||||
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
|
||||
AC_SUBST(PY_ENABLE_SHARED)
|
||||
|
|
Loading…
Reference in a new issue