meson: update to 0.55.0
Remove upstreamed patch and add distutils one. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
4a798f14e9
commit
c7057755cd
3 changed files with 46 additions and 37 deletions
|
@ -1,11 +1,11 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=meson
|
||||
PKG_VERSION:=0.54.3
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.55.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PYPI_NAME:=meson
|
||||
PKG_HASH:=f2bdf4cf0694e696b48261cdd14380fb1d0fe33d24744d8b2df0c12f33ebb662
|
||||
PKG_HASH:=0a1ae2bfe2ae14ac47593537f93290fb79e9b775c55b4c53c282bc3ca3745b35
|
||||
|
||||
PKG_MAINTAINER:=Andre Heider <a.heider@gmail.com>
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
|
|
|
@ -1,34 +0,0 @@
|
|||
From 4db4fd79d9bb2b98cea1117f22b6c97942ab2ecd Mon Sep 17 00:00:00 2001
|
||||
From: Eric Le Bihan <eric.le.bihan.dev@free.fr>
|
||||
Date: Sat, 14 Jul 2018 11:18:45 +0200
|
||||
Subject: [PATCH] Only fix RPATH if install_rpath is not empty
|
||||
|
||||
Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
|
||||
[Fix: remove leftover from original/unconditional code]
|
||||
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
||||
---
|
||||
mesonbuild/minstall.py | 10 ++++++++--
|
||||
1 file changed, 8 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/mesonbuild/minstall.py b/mesonbuild/minstall.py
|
||||
index 8ac6aab1..7ef04116 100644
|
||||
--- a/mesonbuild/minstall.py
|
||||
+++ b/mesonbuild/minstall.py
|
||||
@@ -508,8 +508,14 @@ class Installer:
|
||||
if file_copied:
|
||||
self.did_install_something = True
|
||||
try:
|
||||
- depfixer.fix_rpath(outname, install_rpath, final_path,
|
||||
- install_name_mappings, verbose=False)
|
||||
+ # Buildroot check-host-rpath script expects RPATH
|
||||
+ # But if install_rpath is empty, it will stripped.
|
||||
+ # So, preserve it in this case
|
||||
+ if install_rpath:
|
||||
+ depfixer.fix_rpath(outname, install_rpath, final_path,
|
||||
+ install_name_mappings, verbose=False)
|
||||
+ else:
|
||||
+ print("Skipping RPATH fixing")
|
||||
except SystemExit as e:
|
||||
if isinstance(e.code, int) and e.code == 0:
|
||||
pass
|
||||
|
43
devel/meson/patches/010-no-distutils.patch
Normal file
43
devel/meson/patches/010-no-distutils.patch
Normal file
|
@ -0,0 +1,43 @@
|
|||
From 18955611bafb1924fd1e188359f62d0799acb77e Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Hugo=20Beauz=C3=A9e-Luyssen?= <hugo@beauzee.fr>
|
||||
Date: Fri, 24 Apr 2020 15:40:01 +0200
|
||||
Subject: [PATCH] modules: python: Fix python detection without distutils
|
||||
module
|
||||
|
||||
If distutils isn't present but not required by the called, we can still
|
||||
return a valid python installation
|
||||
---
|
||||
mesonbuild/modules/python.py | 13 ++++++++-----
|
||||
1 file changed, 8 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/mesonbuild/modules/python.py b/mesonbuild/modules/python.py
|
||||
index a5c58a25c3..31406847a3 100644
|
||||
--- a/mesonbuild/modules/python.py
|
||||
+++ b/mesonbuild/modules/python.py
|
||||
@@ -266,10 +266,13 @@ import sys
|
||||
install_paths = sysconfig.get_paths(scheme='posix_prefix', vars={'base': '', 'platbase': '', 'installed_base': ''})
|
||||
|
||||
def links_against_libpython():
|
||||
- from distutils.core import Distribution, Extension
|
||||
- cmd = Distribution().get_command_obj('build_ext')
|
||||
- cmd.ensure_finalized()
|
||||
- return bool(cmd.get_libraries(Extension('dummy', [])))
|
||||
+ try:
|
||||
+ from distutils.core import Distribution, Extension
|
||||
+ cmd = Distribution().get_command_obj('build_ext')
|
||||
+ cmd.ensure_finalized()
|
||||
+ return bool(cmd.get_libraries(Extension('dummy', [])))
|
||||
+ except ModuleNotFoundError:
|
||||
+ return False
|
||||
|
||||
print (json.dumps ({
|
||||
'variables': sysconfig.get_config_vars(),
|
||||
@@ -585,7 +588,7 @@ class PythonModule(ExtensionModule):
|
||||
else:
|
||||
res = ExternalProgramHolder(NonExistingExternalProgram(), state.subproject)
|
||||
if required:
|
||||
- raise mesonlib.MesonException('{} is not a valid python or it is missing setuptools'.format(python))
|
||||
+ raise mesonlib.MesonException('{} is not a valid python'.format(python))
|
||||
|
||||
return res
|
||||
|
Loading…
Reference in a new issue