ocserv: updated to 0.10.11
Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
This commit is contained in:
parent
93f35fc88e
commit
c63841baa6
2 changed files with 3 additions and 40 deletions
|
@ -8,14 +8,14 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=ocserv
|
PKG_NAME:=ocserv
|
||||||
PKG_VERSION:=0.10.10
|
PKG_VERSION:=0.10.11
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=1
|
||||||
PKG_USE_MIPS16:=0
|
PKG_USE_MIPS16:=0
|
||||||
|
|
||||||
PKG_BUILD_DIR :=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR :=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=ftp://ftp.infradead.org/pub/ocserv/
|
PKG_SOURCE_URL:=ftp://ftp.infradead.org/pub/ocserv/
|
||||||
PKG_MD5SUM:=1f73ccb66d36cd51279323e95ae99e68
|
PKG_MD5SUM:=7daf9f105b115cd6611a2ac016a29d24
|
||||||
|
|
||||||
PKG_LICENSE:=GPLv2
|
PKG_LICENSE:=GPLv2
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
|
@ -1,37 +0,0 @@
|
||||||
From 78ebe6c1dab648e3190363cb38ad5be356884494 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Nikos Mavrogiannopoulos <nmav@gnutls.org>
|
|
||||||
Date: Tue, 5 Jan 2016 21:37:35 +0100
|
|
||||||
Subject: [PATCH] don't attempt to open per_user_dir if it is NULL
|
|
||||||
|
|
||||||
This addresses a crash in certain libc's.
|
|
||||||
---
|
|
||||||
src/config.c | 5 ++++-
|
|
||||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/config.c b/src/config.c
|
|
||||||
index 827a7a0..50db655 100644
|
|
||||||
--- a/src/config.c
|
|
||||||
+++ b/src/config.c
|
|
||||||
@@ -617,6 +617,9 @@ static void load_iroutes(struct cfg_st *config)
|
|
||||||
struct dirent *r;
|
|
||||||
char path[_POSIX_PATH_MAX];
|
|
||||||
|
|
||||||
+ if (config->per_user_dir == NULL)
|
|
||||||
+ return;
|
|
||||||
+
|
|
||||||
dir = opendir(config->per_user_dir);
|
|
||||||
if (dir != NULL) {
|
|
||||||
do {
|
|
||||||
@@ -626,8 +629,8 @@ static void load_iroutes(struct cfg_st *config)
|
|
||||||
append_iroutes_from_file(config, path);
|
|
||||||
}
|
|
||||||
} while(r != NULL);
|
|
||||||
+ closedir(dir);
|
|
||||||
}
|
|
||||||
- closedir(dir);
|
|
||||||
}
|
|
||||||
|
|
||||||
static void parse_cfg_file(void *pool, const char* file, struct perm_cfg_st *perm_config, unsigned reload)
|
|
||||||
--
|
|
||||||
2.5.1
|
|
||||||
|
|
Loading…
Reference in a new issue