mxml: copy from oldpackages and update Makefile slightly
Signed-off-by: Espen Jürgensen <espenjurgensen+openwrt@gmail.com>
This commit is contained in:
parent
560598ca22
commit
c606a0a040
2 changed files with 67 additions and 0 deletions
56
libs/mxml/Makefile
Normal file
56
libs/mxml/Makefile
Normal file
|
@ -0,0 +1,56 @@
|
|||
#
|
||||
# Copyright (C) 2006-2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mxml
|
||||
PKG_VERSION:=2.8
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=d85ee6d30de053581242c4a86e79a5d2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.msweet.org/files/project3/
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
PKG_MAINTAINER:=Espen Jürgensen <espenjurgensen+openwrt@gmail.com>
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/mxml
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=Mini-XML
|
||||
URL:=http://www.minixml.org/
|
||||
endef
|
||||
|
||||
define Package/mxml/description
|
||||
A small xml library.
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-shared \
|
||||
--enable-static
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(1)/usr/include
|
||||
$(CP) $(PKG_BUILD_DIR)/mxml.h $(1)/usr/include/
|
||||
mkdir -p $(1)/usr/lib
|
||||
$(CP) $(PKG_BUILD_DIR)/libmxml.so* $(1)/usr/lib/
|
||||
mkdir -p $(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_BUILD_DIR)/mxml.pc $(1)/usr/lib/pkgconfig/
|
||||
endef
|
||||
|
||||
define Package/mxml/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_BUILD_DIR)/libmxml.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,mxml))
|
11
libs/mxml/patches/001-targets.patch
Normal file
11
libs/mxml/patches/001-targets.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -88,7 +88,7 @@ PUBLIBOBJS = mxml-attr.o mxml-entity.o m
|
||||
mxml-index.o mxml-node.o mxml-search.o mxml-set.o
|
||||
LIBOBJS = $(PUBLIBOBJS) mxml-private.o mxml-string.o
|
||||
OBJS = mxmldoc.o testmxml.o $(LIBOBJS)
|
||||
-TARGETS = $(LIBMXML) mxmldoc testmxml mxml.xml doc/mxml.man
|
||||
+TARGETS = $(LIBMXML)
|
||||
|
||||
|
||||
#
|
Loading…
Reference in a new issue