grilo-plugins: update to 0.3.5
Signed-off-by: W. Michael Petullo <mike@flyn.org>
This commit is contained in:
parent
108ec9e955
commit
c5de0c7f8a
3 changed files with 124 additions and 60 deletions
|
@ -8,7 +8,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=grilo-plugins
|
||||
PKG_VERSION:=0.3.2
|
||||
PKG_VERSION:=0.3.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||
|
@ -18,7 +18,7 @@ PKG_LICENSE_FILES:=COPYING
|
|||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@GNOME/grilo-plugins/0.3/
|
||||
PKG_HASH:=791b89289781272c001545931a8f58f499d14e46e038a9caa82dfe2494301afd
|
||||
PKG_HASH:=2977827b8ecb3e15535236180e57dc35e85058d111349bdb6a1597e62a5068fb
|
||||
|
||||
PKG_BUILD_DEPENDS:=glib2 grilo
|
||||
|
||||
|
|
|
@ -1,58 +0,0 @@
|
|||
From 3cd7fb6af73ca7fdef2557ad31b5c4180534d775 Mon Sep 17 00:00:00 2001
|
||||
From: "W. Michael Petullo" <mike@flyn.org>
|
||||
Date: Sat, 9 Jul 2016 09:50:00 -0400
|
||||
Subject: [PATCH] dmap: Add album disc number mapping
|
||||
|
||||
Signed-off-by: W. Michael Petullo <mike@flyn.org>
|
||||
---
|
||||
src/dmap/grl-daap-db.c | 7 +++++++
|
||||
src/dmap/grl-daap.c | 1 +
|
||||
2 files changed, 8 insertions(+)
|
||||
|
||||
diff --git a/src/dmap/grl-daap-db.c b/src/dmap/grl-daap-db.c
|
||||
index 4850073..5bcd804 100644
|
||||
--- a/src/dmap/grl-daap-db.c
|
||||
+++ b/src/dmap/grl-daap-db.c
|
||||
@@ -161,6 +161,7 @@ grl_daap_db_add (DMAPDb *_db, DMAPRecord *_record)
|
||||
|
||||
gint duration = 0;
|
||||
gint32 bitrate = 0,
|
||||
+ disc = 0,
|
||||
track = 0;
|
||||
gchar *id_s = NULL,
|
||||
*title = NULL,
|
||||
@@ -186,6 +187,8 @@ grl_daap_db_add (DMAPDb *_db, DMAPRecord *_record)
|
||||
&title,
|
||||
"track",
|
||||
&track,
|
||||
+ "disc",
|
||||
+ &disc,
|
||||
"location",
|
||||
&url,
|
||||
"has-video",
|
||||
@@ -217,6 +220,10 @@ grl_daap_db_add (DMAPDb *_db, DMAPRecord *_record)
|
||||
grl_media_set_bitrate (media, bitrate);
|
||||
grl_media_set_track_number (media, track);
|
||||
|
||||
+ if (disc != 0) {
|
||||
+ grl_media_set_album_disc_number (media, disc);
|
||||
+ }
|
||||
+
|
||||
if (album) {
|
||||
grl_media_set_album (media, album);
|
||||
}
|
||||
diff --git a/src/dmap/grl-daap.c b/src/dmap/grl-daap.c
|
||||
index 59aa981..796234d 100644
|
||||
--- a/src/dmap/grl-daap.c
|
||||
+++ b/src/dmap/grl-daap.c
|
||||
@@ -365,6 +365,7 @@ grl_daap_source_supported_keys (GrlSource *source)
|
||||
|
||||
if (!keys) {
|
||||
keys = grl_metadata_key_list_new (GRL_METADATA_KEY_ALBUM,
|
||||
+ GRL_METADATA_KEY_ALBUM_DISC_NUMBER,
|
||||
GRL_METADATA_KEY_ARTIST,
|
||||
GRL_METADATA_KEY_BITRATE,
|
||||
GRL_METADATA_KEY_DURATION,
|
||||
--
|
||||
2.7.4
|
||||
|
|
@ -0,0 +1,122 @@
|
|||
diff -u --recursive grilo-plugins-0.3.5-vanilla/configure grilo-plugins-0.3.5/configure
|
||||
--- grilo-plugins-0.3.5-vanilla/configure 2018-01-07 21:45:18.874540074 -0500
|
||||
+++ grilo-plugins-0.3.5/configure 2018-01-07 21:46:31.145749381 -0500
|
||||
@@ -638,8 +638,6 @@
|
||||
LTLIBOBJS
|
||||
LIBOBJS
|
||||
YELP_HELP_RULES
|
||||
-XMLLINT
|
||||
-ITSTOOL
|
||||
HELP_DIR
|
||||
YELP_LC_DIST
|
||||
YELP_LC_MEDIA_LINKS
|
||||
@@ -1084,9 +1082,7 @@
|
||||
GOM_CFLAGS
|
||||
GOM_LIBS
|
||||
TRACKER_SPARQL_CFLAGS
|
||||
-TRACKER_SPARQL_LIBS
|
||||
-ITSTOOL
|
||||
-XMLLINT'
|
||||
+TRACKER_SPARQL_LIBS'
|
||||
|
||||
|
||||
# Initialize some variables set by options.
|
||||
@@ -1855,8 +1851,6 @@
|
||||
C compiler flags for TRACKER_SPARQL, overriding pkg-config
|
||||
TRACKER_SPARQL_LIBS
|
||||
linker flags for TRACKER_SPARQL, overriding pkg-config
|
||||
- ITSTOOL Path to the `itstool` command
|
||||
- XMLLINT Path to the `xmllint` command
|
||||
|
||||
Use these variables to override the choices made by `configure' or to help
|
||||
it to find libraries and programs with nonstandard names/locations.
|
||||
@@ -16976,89 +16970,6 @@
|
||||
|
||||
|
||||
|
||||
-# Extract the first word of "itstool", so it can be a program name with args.
|
||||
-set dummy itstool; ac_word=$2
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
|
||||
-$as_echo_n "checking for $ac_word... " >&6; }
|
||||
-if ${ac_cv_prog_ITSTOOL+:} false; then :
|
||||
- $as_echo_n "(cached) " >&6
|
||||
-else
|
||||
- if test -n "$ITSTOOL"; then
|
||||
- ac_cv_prog_ITSTOOL="$ITSTOOL" # Let the user override the test.
|
||||
-else
|
||||
-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
|
||||
-for as_dir in $PATH
|
||||
-do
|
||||
- IFS=$as_save_IFS
|
||||
- test -z "$as_dir" && as_dir=.
|
||||
- for ac_exec_ext in '' $ac_executable_extensions; do
|
||||
- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
|
||||
- ac_cv_prog_ITSTOOL="itstool"
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
||||
- break 2
|
||||
- fi
|
||||
-done
|
||||
- done
|
||||
-IFS=$as_save_IFS
|
||||
-
|
||||
-fi
|
||||
-fi
|
||||
-ITSTOOL=$ac_cv_prog_ITSTOOL
|
||||
-if test -n "$ITSTOOL"; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ITSTOOL" >&5
|
||||
-$as_echo "$ITSTOOL" >&6; }
|
||||
-else
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-if test x"$ITSTOOL" = x; then
|
||||
- as_fn_error $? "itstool not found" "$LINENO" 5
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-# Extract the first word of "xmllint", so it can be a program name with args.
|
||||
-set dummy xmllint; ac_word=$2
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
|
||||
-$as_echo_n "checking for $ac_word... " >&6; }
|
||||
-if ${ac_cv_prog_XMLLINT+:} false; then :
|
||||
- $as_echo_n "(cached) " >&6
|
||||
-else
|
||||
- if test -n "$XMLLINT"; then
|
||||
- ac_cv_prog_XMLLINT="$XMLLINT" # Let the user override the test.
|
||||
-else
|
||||
-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
|
||||
-for as_dir in $PATH
|
||||
-do
|
||||
- IFS=$as_save_IFS
|
||||
- test -z "$as_dir" && as_dir=.
|
||||
- for ac_exec_ext in '' $ac_executable_extensions; do
|
||||
- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
|
||||
- ac_cv_prog_XMLLINT="xmllint"
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
||||
- break 2
|
||||
- fi
|
||||
-done
|
||||
- done
|
||||
-IFS=$as_save_IFS
|
||||
-
|
||||
-fi
|
||||
-fi
|
||||
-XMLLINT=$ac_cv_prog_XMLLINT
|
||||
-if test -n "$XMLLINT"; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $XMLLINT" >&5
|
||||
-$as_echo "$XMLLINT" >&6; }
|
||||
-else
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-if test x"$XMLLINT" = x; then
|
||||
- as_fn_error $? "xmllint not found" "$LINENO" 5
|
||||
-fi
|
||||
-
|
||||
YELP_HELP_RULES='
|
||||
HELP_ID ?=
|
||||
HELP_POT ?=
|
Loading…
Reference in a new issue