usbmuxd: Update to latest master
usbmuxd must be ran for many of the idevice tools. Added an init
script to make this easier.
Added myself as maintainer.
Fix PKG_CVE_ID.
Added config directory.
Placed in a submenu for easier readability.
Add extra tool
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit fb7ed3d996
)
This commit is contained in:
parent
0d0820d43b
commit
c5aae4a768
3 changed files with 44 additions and 8 deletions
|
@ -8,18 +8,18 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=usbmuxd
|
||||
PKG_SOURCE_DATE:=2019-11-11
|
||||
PKG_SOURCE_VERSION:=9af2b12552693a47601347e1eafc1e94132d727e
|
||||
PKG_SOURCE_DATE:=2019-12-16
|
||||
PKG_SOURCE_VERSION:=ec5ff91cfabd30637f8af8f5c79baf4d7818ce57
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL=https://github.com/libimobiledevice/usbmuxd
|
||||
PKG_MIRROR_HASH:=f0b8a5c7ec1625c06b52b4403696c2b6bcbc0da5256bc097b7db053fb14b6892
|
||||
PKG_MIRROR_HASH:=1d0f2fa3842fbcbebe4b7d323829703e29a3c1a078c62b4a783e4c99a8a2f576
|
||||
|
||||
PKG_MAINTAINER:=
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING.GPLv2
|
||||
PKG_CPE_ID:=cpe:/a:nikias_bassen:usbmuxd
|
||||
PKG_CPE_ID:=cpe:/a:libimobiledevice:usbmuxd
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
|
@ -30,8 +30,9 @@ include $(INCLUDE_DIR)/package.mk
|
|||
define Package/usbmuxd
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
SUBMENU:=libimobiledevice
|
||||
TITLE:=USB multiplexing daemon
|
||||
URL:=http://www.libimobiledevice.org/
|
||||
URL:=https://www.libimobiledevice.org/
|
||||
DEPENDS:=+librt +libusb-1.0 +libusbmuxd +libopenssl +libimobiledevice
|
||||
endef
|
||||
|
||||
|
@ -43,11 +44,18 @@ define Package/usbmuxd/description
|
|||
uses a dedicated USB interface as a virtual network device.
|
||||
endef
|
||||
|
||||
define Package/usbmuxd/conffiles
|
||||
/etc/lockdown
|
||||
/etc/lockdown/SystemConfiguration.plist
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += --without-systemd
|
||||
|
||||
define Package/usbmuxd/install
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) ./files/usbmuxd.init $(1)/etc/init.d/usbmuxd
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/usbmuxd $(1)/usr/sbin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/usbmuxd $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,usbmuxd))
|
||||
|
|
17
utils/usbmuxd/files/usbmuxd.init
Normal file
17
utils/usbmuxd/files/usbmuxd.init
Normal file
|
@ -0,0 +1,17 @@
|
|||
#!/bin/sh /etc/rc.common
|
||||
|
||||
START=94
|
||||
|
||||
USE_PROCD=1
|
||||
PROG=/usr/sbin/usbmuxd
|
||||
|
||||
start_service() {
|
||||
procd_open_instance
|
||||
procd_set_param command $PROG -f
|
||||
procd_set_param stderr 1
|
||||
procd_close_instance
|
||||
}
|
||||
|
||||
reload_service() {
|
||||
procd_send_signal $PROG
|
||||
}
|
11
utils/usbmuxd/patches/010-config.patch
Normal file
11
utils/usbmuxd/patches/010-config.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/src/conf.c
|
||||
+++ b/src/conf.c
|
||||
@@ -126,7 +126,7 @@ const char *config_get_config_dir()
|
||||
#ifdef __APPLE__
|
||||
base_config_dir = strdup("/var/db");
|
||||
#else
|
||||
- base_config_dir = strdup("/var/lib");
|
||||
+ base_config_dir = strdup("/etc");
|
||||
#endif
|
||||
#endif
|
||||
__config_dir = string_concat(base_config_dir, DIR_SEP_S, CONFIG_DIR, NULL);
|
Loading…
Reference in a new issue