Nano: Update to 2.6.3, backport patch from trunk to fix compile
Signed-off-by: Jonathan Bennett <jbennett@incomsystems.biz>
This commit is contained in:
parent
f2e1de58e6
commit
c57f915028
2 changed files with 20 additions and 2 deletions
|
@ -8,14 +8,14 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=nano
|
PKG_NAME:=nano
|
||||||
PKG_VERSION:=2.6.0
|
PKG_VERSION:=2.6.3
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_LICENSE:=GPL-3.0+
|
PKG_LICENSE:=GPL-3.0+
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://www.nano-editor.org/dist/v2.6/
|
PKG_SOURCE_URL:=https://www.nano-editor.org/dist/v2.6/
|
||||||
PKG_MD5SUM:=89051965a1de963190696348bc291b86
|
PKG_MD5SUM:=1213c7f17916e65afefc95054c1f90f9
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
18
utils/nano/patches/010-fix-enable-tiny
Normal file
18
utils/nano/patches/010-fix-enable-tiny
Normal file
|
@ -0,0 +1,18 @@
|
||||||
|
--- nano-2.6.3/src/winio.c 2016-08-10 04:22:23.000000000 -0500
|
||||||
|
+++ nano-2.6.3.new/src/winio.c 2016-08-17 00:58:35.663135848 -0500
|
||||||
|
@@ -502,7 +502,6 @@
|
||||||
|
return sc_seq_or(do_prev_block, 0);
|
||||||
|
else if (retval == controldown)
|
||||||
|
return sc_seq_or(do_next_block, 0);
|
||||||
|
-#endif
|
||||||
|
|
||||||
|
/* When not running under X, check for the bare arrow keys whether
|
||||||
|
* the Ctrl key is being held together with them. */
|
||||||
|
@@ -521,6 +520,7 @@
|
||||||
|
return sc_seq_or(do_next_word_void, 0);
|
||||||
|
}
|
||||||
|
}
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
switch (retval) {
|
||||||
|
#ifdef KEY_SLEFT
|
Loading…
Reference in a new issue