stunnel: Update from 5.14 to 5.20
* 010_fix_getnameinfo.patch is no longer needed * 011-cron-without-pthread-fix.patch added, fixes incorrect ifdef when building without pthreads Signed-off-by: Michael Haas <haas@computerlinguist.org>
This commit is contained in:
parent
f15b0ace72
commit
c544adacd4
3 changed files with 16 additions and 27 deletions
|
@ -8,7 +8,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=stunnel
|
||||
PKG_VERSION:=5.14
|
||||
PKG_VERSION:=5.20
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_LICENSE:=GPL-2.0+
|
||||
|
@ -17,7 +17,7 @@ PKG_LICENSE_FILES:=COPYING COPYRIGHT.GPL
|
|||
|
||||
PKG_SOURCE_URL:=http://stunnel.cybermirror.org/archive/5.x/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_MD5SUM:=e716501960dc6856d80f92547298f724
|
||||
PKG_MD5SUM:=3264375026c2b496b5d258e243222de8
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
--- a/src/prototypes.h
|
||||
+++ b/src/prototypes.h
|
||||
@@ -590,7 +590,7 @@ extern GETNAMEINFO s_getnameinfo;
|
||||
|
||||
#endif /* USE_WIN32 */
|
||||
|
||||
-int getnameinfo(const struct sockaddr *, int, char *, int, char *, int, int);
|
||||
+int getnameinfo(const struct sockaddr *, socklen_t, char *, socklen_t, char *, socklen_t, unsigned int);
|
||||
|
||||
#endif /* !defined HAVE_GETNAMEINFO */
|
||||
|
||||
--- a/src/resolver.c
|
||||
+++ b/src/resolver.c
|
||||
@@ -538,8 +538,9 @@ const char *s_gai_strerror(int err) {
|
||||
/* implementation is limited to functionality needed by stunnel */
|
||||
|
||||
#ifndef HAVE_GETNAMEINFO
|
||||
-int getnameinfo(const struct sockaddr *sa, int salen,
|
||||
- char *host, int hostlen, char *serv, int servlen, int flags) {
|
||||
+int getnameinfo(const struct sockaddr *sa, socklen_t salen,
|
||||
+ char *host, socklen_t hostlen, char *serv, socklen_t servlen,
|
||||
+ unsigned int flags) {
|
||||
|
||||
#if defined(USE_WIN32) && !defined(_WIN32_WCE)
|
||||
if(s_getnameinfo)
|
14
net/stunnel/patches/012-cron-without-pthread-fix.patch
Normal file
14
net/stunnel/patches/012-cron-without-pthread-fix.patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
Index: stunnel-5.20/src/cron.c
|
||||
===================================================================
|
||||
--- stunnel-5.20.orig/src/cron.c
|
||||
+++ stunnel-5.20/src/cron.c
|
||||
@@ -46,6 +46,9 @@ NOEXPORT void cron_thread(void *arg);
|
||||
#endif
|
||||
#if defined(USE_PTHREAD) || defined(USE_WIN32)
|
||||
NOEXPORT void cron_worker(void);
|
||||
+#endif
|
||||
+
|
||||
+#ifndef OPENSSL_NO_DH
|
||||
NOEXPORT void cron_dh_param(void);
|
||||
#endif
|
||||
|
Loading…
Reference in a new issue