tmux: update to 2.1
Signed-off-by: Maxim Storchak <m.storchak@gmail.com>
This commit is contained in:
parent
5ec2a5e810
commit
c53c5306a6
2 changed files with 20 additions and 14 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=tmux
|
||||
PKG_VERSION:=2.0
|
||||
PKG_VERSION:=2.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/tmux/tmux/releases/download/$(PKG_VERSION)
|
||||
PKG_MD5SUM:=9fb6b443392c3978da5d599f1e814eaa
|
||||
PKG_MD5SUM:=74a2855695bccb51b6e301383ad4818c
|
||||
PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
|
||||
|
||||
PKG_LICENSE:=ISC
|
||||
|
|
|
@ -1,6 +1,8 @@
|
|||
diff --git a/compat.h b/compat.h
|
||||
index 8666a1d..2a44a2b 100644
|
||||
--- a/compat.h
|
||||
+++ b/compat.h
|
||||
@@ -230,7 +230,9 @@ int daemon(int, int);
|
||||
@@ -223,7 +223,9 @@ int daemon(int, int);
|
||||
#ifndef HAVE_B64_NTOP
|
||||
/* b64_ntop.c */
|
||||
#undef b64_ntop /* for Cygwin */
|
||||
|
@ -11,17 +13,8 @@
|
|||
#endif
|
||||
|
||||
#ifndef HAVE_FORKPTY
|
||||
--- a/tty.c
|
||||
+++ b/tty.c
|
||||
@@ -1070,7 +1070,7 @@ tty_cmd_setselection(struct tty *tty, co
|
||||
off = 4 * ((ctx->num + 2) / 3) + 1; /* storage for base64 */
|
||||
buf = xmalloc(off);
|
||||
|
||||
- b64_ntop(ctx->ptr, ctx->num, buf, off);
|
||||
+ local_b64_ntop(ctx->ptr, ctx->num, buf, off);
|
||||
tty_putcode_ptr2(tty, TTYC_MS, "", buf);
|
||||
|
||||
free(buf);
|
||||
diff --git a/compat/b64_ntop.c b/compat/b64_ntop.c
|
||||
index 2b4dc2d..a1314ca 100644
|
||||
--- a/compat/b64_ntop.c
|
||||
+++ b/compat/b64_ntop.c
|
||||
@@ -122,7 +122,7 @@ static const char Pad64 = '=';
|
||||
|
@ -33,3 +26,16 @@
|
|||
size_t datalength = 0;
|
||||
uint8_t input[3];
|
||||
uint8_t output[4];
|
||||
diff --git a/tty.c b/tty.c
|
||||
index 7be952c..06dedab 100644
|
||||
--- a/tty.c
|
||||
+++ b/tty.c
|
||||
@@ -1134,7 +1134,7 @@ tty_cmd_setselection(struct tty *tty, const struct tty_ctx *ctx)
|
||||
off = 4 * ((ctx->num + 2) / 3) + 1; /* storage for base64 */
|
||||
buf = xmalloc(off);
|
||||
|
||||
- b64_ntop(ctx->ptr, ctx->num, buf, off);
|
||||
+ local_b64_ntop(ctx->ptr, ctx->num, buf, off);
|
||||
tty_putcode_ptr2(tty, TTYC_MS, "", buf);
|
||||
|
||||
free(buf);
|
||||
|
|
Loading…
Reference in a new issue