moreutils: Add package
Signed-off-by: Nikil Mehta <nikil.mehta@gmail.com>
This commit is contained in:
parent
0fcdd8d84d
commit
c4a7b1466a
2 changed files with 82 additions and 0 deletions
61
utils/moreutils/Makefile
Normal file
61
utils/moreutils/Makefile
Normal file
|
@ -0,0 +1,61 @@
|
|||
#
|
||||
# Copyright (C) 2016 Nikil Mehta <nikil.mehta@gmail.com>
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=moreutils
|
||||
PKG_VERSION:=0.60
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.xz
|
||||
PKG_SOURCE_URL:=http://http.debian.net/debian/pool/main/m/moreutils/
|
||||
PKG_HASH:=e42d18bacbd2d003779a55fb3542befa5d1d217ee37c1874e8c497581ebc17c5
|
||||
|
||||
PKG_MAINTAINER:=Nikil Mehta <nikil.mehta@gmail.com>
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/moreutils
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=additional Unix utilities
|
||||
URL:=https://joeyh.name/code/moreutils/
|
||||
DEPENDS:=+perl +perlbase-file +perlbase-getopt +perlbase-io +perlbase-ipc +perlbase-posix
|
||||
endef
|
||||
|
||||
define Package/moreutils/description
|
||||
This is a growing collection of the Unix tools that nobody thought
|
||||
to write long ago, when Unix was young.
|
||||
.
|
||||
So far, it includes the following utilities:
|
||||
- chronic: runs a command quietly unless it fails
|
||||
- combine: combine the lines in two files using boolean operations
|
||||
- errno: look up errno names and descriptions
|
||||
- ifdata: get network interface info without parsing ifconfig output
|
||||
- ifne: run a program if the standard input is not empty
|
||||
- isutf8: check if a file or standard input is utf-8
|
||||
- lckdo: execute a program with a lock held
|
||||
- mispipe: pipe two commands, returning the exit status of the first
|
||||
- parallel: run multiple jobs at once
|
||||
- pee: tee standard input to pipes
|
||||
- sponge: soak up standard input and write to a file
|
||||
- ts: timestamp standard input
|
||||
- vidir: edit a directory in your text editor
|
||||
- vipe: insert a text editor into a pipe
|
||||
- zrun: automatically uncompress arguments to command
|
||||
endef
|
||||
|
||||
define Package/moreutils/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,moreutils))
|
21
utils/moreutils/patches/001_disable-manuals.patch
Normal file
21
utils/moreutils/patches/001_disable-manuals.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -13,7 +13,7 @@
|
||||
|
||||
DOCBOOK2XMAN=xsltproc --param man.authors.section.enabled 0 $(DOCBOOKXSL)/manpages/docbook.xsl
|
||||
|
||||
-all: $(BINS) $(MANS)
|
||||
+all: $(BINS)
|
||||
|
||||
clean:
|
||||
rm -f $(BINS) $(MANS) dump.c errnos.h errno.o
|
||||
@@ -27,9 +27,6 @@
|
||||
$(INSTALL_BIN) $(BINS) $(DESTDIR)$(PREFIX)/bin
|
||||
install $(PERLSCRIPTS) $(DESTDIR)$(PREFIX)/bin
|
||||
|
||||
- mkdir -p $(DESTDIR)$(PREFIX)/share/man/man1
|
||||
- install $(MANS) $(DESTDIR)$(PREFIX)/share/man/man1
|
||||
-
|
||||
check: isutf8
|
||||
./is_utf8/test.sh
|
||||
|
Loading…
Reference in a new issue