diff --git a/libs/libyubikey/Makefile b/libs/libyubikey/Makefile
index 486a54525..37e20f3dd 100644
--- a/libs/libyubikey/Makefile
+++ b/libs/libyubikey/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libyubikey
 PKG_VERSION:=1.13
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=libyubikey-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://developers.yubico.com/yubico-c/Releases
@@ -16,7 +16,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/libyubikey
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=The Yuibco yubikey c library
+  TITLE:=The Yubico yubikey c library
   URL:=https://developers.yubico.com/yubico-c/
 endef
 
diff --git a/libs/yubico-pam/Makefile b/libs/yubico-pam/Makefile
index 7742832c1..fddf337d5 100644
--- a/libs/yubico-pam/Makefile
+++ b/libs/yubico-pam/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=yubico-pam
 PKG_VERSION:=2.26
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=pam_yubico-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://developers.yubico.com/yubico-pam/Releases
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/yubico-pam
 	SECTION:=libs
 	CATEGORY:=Libraries
-	TITLE:=The Yuibco PAM module
+	TITLE:=The Yubico PAM module
 	URL:=https://developers.yubico.com/yubico-pam/
 	DEPENDS:=+ykclient +ykpers +libyubikey +libpam +curl
 endef
diff --git a/utils/ykclient/Makefile b/utils/ykclient/Makefile
index e6541437c..2e7af5cd4 100644
--- a/utils/ykclient/Makefile
+++ b/utils/ykclient/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ykclient
 PKG_VERSION:=2.15
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=ykclient-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://developers.yubico.com/yubico-c-client/Releases/
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/ykclient
   SECTION:=utils
   CATEGORY:=Utilities
-  TITLE:=The Yuibco yubikey c client library
+  TITLE:=The Yubico yubikey c client library
   URL:=https://developers.yubico.com/yubico-c-client/
   DEPENDS:=curl
 endef
diff --git a/utils/ykpers/Makefile b/utils/ykpers/Makefile
index 7c2261c5e..ab3d10cac 100644
--- a/utils/ykpers/Makefile
+++ b/utils/ykpers/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ykpers
 PKG_VERSION:=1.20.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://developers.yubico.com/yubikey-personalization/Releases
@@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/ykpers
   SECTION:=utils
   CATEGORY:=Utilities
-  TITLE:=The Yuibco personalization package
+  TITLE:=The Yubico personalization package
   URL:=https://developers.yubico.com/yubikey-personalization/
   DEPENDS:=+curl +libyubikey +libjson-c +libusb-1.0
 endef
diff --git a/utils/ykpers/patches/020-json-c-0.14.patch b/utils/ykpers/patches/020-json-c-0.14.patch
index ca5a918d2..2bb27c91d 100644
--- a/utils/ykpers/patches/020-json-c-0.14.patch
+++ b/utils/ykpers/patches/020-json-c-0.14.patch
@@ -9,8 +9,6 @@ Upstream removed the TRUE and FALSE defines in commit
  ykpers-json.c | 18 +++++++++---------
  1 file changed, 9 insertions(+), 9 deletions(-)
 
-diff --git a/ykpers-json.c b/ykpers-json.c
-index a62e907..15ad380 100644
 --- a/ykpers-json.c
 +++ b/ykpers-json.c
 @@ -40,7 +40,7 @@
@@ -22,7 +20,7 @@ index a62e907..15ad380 100644
  #endif
  
  static void set_json_value(struct map_st *p, int mode, json_object *options, YKP_CONFIG *cfg) {
-@@ -50,7 +50,7 @@ static void set_json_value(struct map_st *p, int mode, json_object *options, YKP
+@@ -50,7 +50,7 @@ static void set_json_value(struct map_st
  	if(p->mode && (mode & p->mode) == mode) {
  		json_object *joption;
  		json_bool ret = yk_json_object_object_get(options, p->json_text, joption);
@@ -31,7 +29,7 @@ index a62e907..15ad380 100644
  			int value = json_object_get_boolean(joption);
  			if(value == 1) {
  				p->setter(cfg, true);
-@@ -230,20 +230,20 @@ int _ykp_json_import_cfg(YKP_CONFIG *cfg, const char *json, size_t len) {
+@@ -230,20 +230,20 @@ int _ykp_json_import_cfg(YKP_CONFIG *cfg
  			ykp_errno = YKP_EINVAL;
  			goto out;
  		}
@@ -56,7 +54,7 @@ index a62e907..15ad380 100644
  			int target_config = json_object_get_int(jtarget);
  			int command;
  			if(target_config == 1) {
-@@ -275,13 +275,13 @@ int _ykp_json_import_cfg(YKP_CONFIG *cfg, const char *json, size_t len) {
+@@ -275,13 +275,13 @@ int _ykp_json_import_cfg(YKP_CONFIG *cfg
  		if(mode == MODE_OATH_HOTP) {
  			json_object *jdigits, *jrandom;
  			ykp_set_tktflag_OATH_HOTP(cfg, true);
@@ -72,7 +70,7 @@ index a62e907..15ad380 100644
  				int random = json_object_get_boolean(jrandom);
  				int seed = 0;
  				if(random == 1) {
-@@ -290,7 +290,7 @@ int _ykp_json_import_cfg(YKP_CONFIG *cfg, const char *json, size_t len) {
+@@ -290,7 +290,7 @@ int _ykp_json_import_cfg(YKP_CONFIG *cfg
  					goto out;
  				} else {
  					json_object *jseed;