transmission: Update to latest git and fix syslog.
The init script runs transmission with the foreground parameter for procd to control it. However, if transmission is ran in the foreground, nothing is logged to syslog. Added a patch to remove this restriction. Also added a sysctl file that removes these warnings: UDP Failed to set receive buffer: requested 4194304, got 262142 (tr-udp.c:75) UDP Please add the line "net.core.rmem_max = 4194304" to /etc/sysctl.conf (tr-udp.c:80) UDP Failed to set send buffer: requested 1048576, got 262142 (tr-udp.c:86) UDP Please add the line "net.core.wmem_max = 1048576" to /etc/sysctl.conf (tr-udp.c:91) Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
5d216df6cd
commit
c11bb018e5
4 changed files with 38 additions and 34 deletions
|
@ -9,14 +9,14 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=transmission
|
||||
PKG_VERSION:=2.92+git
|
||||
PKG_RELEASE:=4
|
||||
PKG_RELEASE:=5
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/transmission/transmission.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=35fea28d1a37875ef7480ac061754df617805b19
|
||||
PKG_SOURCE_VERSION:=5b29fe15561d40c40cbee635446df6b33e18d2c2
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
|
||||
PKG_MIRROR_HASH:=aeeb8dfd918bd2cf4fb6fbdf58bd822e9b509df1ba5ec408888edd161123ef8e
|
||||
PKG_MIRROR_HASH:=f99982ae68564da9bf6ad4407285aff2e29508e4fd801ff56f86a8b3dae01819
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
|
@ -32,7 +32,7 @@ define Package/transmission/template
|
|||
CATEGORY:=Network
|
||||
TITLE:=BitTorrent client
|
||||
URL:=http://www.transmissionbt.com
|
||||
MAINTAINER:=Cezary Jackiewicz <cezary@eko.one.pl>
|
||||
MAINTAINER:=Rosen Penev <rosenp@gmail.com>
|
||||
endef
|
||||
|
||||
define Package/transmission-daemon/Default
|
||||
|
@ -171,6 +171,8 @@ define Package/transmission-daemon-openssl/install
|
|||
$(INSTALL_BIN) files/transmission.init $(1)/etc/init.d/transmission
|
||||
$(INSTALL_DIR) $(1)/etc/config
|
||||
$(INSTALL_CONF) files/transmission.config $(1)/etc/config/transmission
|
||||
$(INSTALL_DIR) $(1)/etc/sysctl.d/
|
||||
$(INSTALL_CONF) files/transmission.sysctl $(1)/etc/sysctl.d/20-transmission.conf
|
||||
endef
|
||||
Package/transmission-daemon-mbedtls/install = $(Package/transmission-daemon-openssl/install)
|
||||
|
||||
|
|
2
net/transmission/files/transmission.sysctl
Normal file
2
net/transmission/files/transmission.sysctl
Normal file
|
@ -0,0 +1,2 @@
|
|||
net.core.rmem_max = 4194304
|
||||
net.core.wmem_max = 1048576
|
|
@ -1,30 +0,0 @@
|
|||
--- a/libtransmission/bitfield.c
|
||||
+++ b/libtransmission/bitfield.c
|
||||
@@ -6,6 +6,8 @@
|
||||
*
|
||||
*/
|
||||
|
||||
+#define __NEED_ssize_t
|
||||
+
|
||||
#include <assert.h>
|
||||
#include <string.h> /* memset */
|
||||
|
||||
@@ -13,6 +15,7 @@
|
||||
#include "bitfield.h"
|
||||
#include "utils.h" /* tr_new0 () */
|
||||
|
||||
+
|
||||
const tr_bitfield TR_BITFIELD_INIT = { NULL, 0, 0, 0, false, false };
|
||||
|
||||
/****
|
||||
--- a/libtransmission/fdlimit.h
|
||||
+++ b/libtransmission/fdlimit.h
|
||||
@@ -10,6 +10,8 @@
|
||||
#error only libtransmission should #include this header.
|
||||
#endif
|
||||
|
||||
+#define __NEED_off_t
|
||||
+
|
||||
#include "transmission.h"
|
||||
#include "file.h"
|
||||
#include "net.h"
|
30
net/transmission/patches/060-fix-foreground-syslog.patch
Normal file
30
net/transmission/patches/060-fix-foreground-syslog.patch
Normal file
|
@ -0,0 +1,30 @@
|
|||
diff --git a/daemon/daemon.c b/daemon/daemon.c
|
||||
index 7b2a3b425..5b19d105a 100644
|
||||
--- a/daemon/daemon.c
|
||||
+++ b/daemon/daemon.c
|
||||
@@ -715,12 +715,7 @@ static int daemon_start(void* raw_arg, bool foreground)
|
||||
}
|
||||
|
||||
#ifdef HAVE_SYSLOG
|
||||
-
|
||||
- if (!foreground)
|
||||
- {
|
||||
- openlog(MY_NAME, LOG_CONS | LOG_PID, LOG_DAEMON);
|
||||
- }
|
||||
-
|
||||
+ openlog(MY_NAME, LOG_CONS | LOG_PID, LOG_DAEMON);
|
||||
#endif
|
||||
|
||||
/* Create new timer event to report daemon status */
|
||||
@@ -772,11 +767,8 @@ cleanup:
|
||||
/* shutdown */
|
||||
#ifdef HAVE_SYSLOG
|
||||
|
||||
- if (!foreground)
|
||||
- {
|
||||
syslog(LOG_INFO, "%s", "Closing session");
|
||||
closelog();
|
||||
- }
|
||||
|
||||
#endif
|
||||
|
Loading…
Reference in a new issue