squid: update to 3.5.2
Signed-off-by: Marko Ratkaj <marko.ratkaj@sartura.hr>
This commit is contained in:
parent
0e6069854f
commit
c05980909c
3 changed files with 23 additions and 22 deletions
|
@ -8,15 +8,15 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=squid
|
||||
PKG_VERSION:=3.4.11
|
||||
PKG_VERSION:=3.5.2
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v3/3.4/
|
||||
PKG_MD5SUM:=e79ddb108d24823da8c1dbc0fc4a31fb
|
||||
PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v3/3.5/
|
||||
PKG_MD5SUM:=0330ec9f69e333c2a81fa4502ba96a22
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
@ -33,7 +33,7 @@ endef
|
|||
define Package/squid
|
||||
$(call Package/squid/Default)
|
||||
MENU:=1
|
||||
DEPENDS:=+libopenssl +libpthread +librt +libltdl +libstdcpp
|
||||
DEPENDS:=+libopenssl +libpthread +librt +libltdl +libstdcpp +libgnutls
|
||||
TITLE:=full-featured Web proxy cache
|
||||
endef
|
||||
|
||||
|
|
|
@ -1,17 +1,17 @@
|
|||
--- a/src/Makefile.in
|
||||
+++ b/src/Makefile.in
|
||||
@@ -7742,7 +7742,7 @@ cache_cf.o: cf_parser.cci
|
||||
@@ -7759,7 +7759,7 @@ cache_cf.o: cf_parser.cci
|
||||
|
||||
# cf_gen builds the configuration files.
|
||||
cf_gen$(EXEEXT): $(cf_gen_SOURCES) $(cf_gen_DEPENDENCIES) cf_gen_defines.cci
|
||||
- $(HOSTCXX) -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
|
||||
- $(BUILDCXX) $(BUILDCXXFLAGS) -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
|
||||
+ g++ -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
|
||||
|
||||
# squid.conf.default is built by cf_gen when making cf_parser.cci
|
||||
squid.conf.default squid.conf.documented: cf_parser.cci
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -22226,7 +22226,7 @@ $as_echo_n "checking whether the SSL_get
|
||||
@@ -22935,7 +22935,7 @@ $as_echo_n "checking whether the SSL_get
|
||||
if test "$cross_compiling" = yes; then :
|
||||
{ { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
||||
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
|
@ -20,7 +20,7 @@
|
|||
See \`config.log' for more details" "$LINENO" 5; }
|
||||
else
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
@@ -22274,7 +22274,7 @@ $as_echo_n "checking whether the workaro
|
||||
@@ -22983,7 +22983,7 @@ $as_echo_n "checking whether the workaro
|
||||
if test "$cross_compiling" = yes; then :
|
||||
{ { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
||||
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
|
@ -29,7 +29,7 @@
|
|||
See \`config.log' for more details" "$LINENO" 5; }
|
||||
else
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
@@ -24924,7 +24924,7 @@ else
|
||||
@@ -28201,7 +28201,7 @@ else
|
||||
if test "$cross_compiling" = yes; then :
|
||||
{ { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
||||
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
|
@ -38,7 +38,7 @@
|
|||
See \`config.log' for more details" "$LINENO" 5; }
|
||||
else
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
@@ -24949,7 +24949,7 @@ else
|
||||
@@ -28226,7 +28226,7 @@ else
|
||||
if test "$cross_compiling" = yes; then :
|
||||
{ { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
||||
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
|
|
|
@ -1,29 +1,30 @@
|
|||
--- a/src/mime.conf.default
|
||||
+++ b/src/mime.conf.default
|
||||
@@ -1,19 +1,3 @@
|
||||
-# This file associates filename extensions (for servers or services
|
||||
-# that don't automatically include them - like ftp) with a mime type
|
||||
@@ -1,20 +1,3 @@
|
||||
-## Copyright (C) 1996-2015 The Squid Software Foundation and contributors
|
||||
-##
|
||||
-## Squid software is distributed under GPLv2+ license and includes
|
||||
-## contributions from numerous individuals and organizations.
|
||||
-## Please see the COPYING and CONTRIBUTORS files for details.
|
||||
-##
|
||||
-#
|
||||
-# This file associates URL patterns for servers or services
|
||||
-# that don't automatically include Content-Type (like ftp) with a mime type
|
||||
-# and a graphical icon.
|
||||
-#
|
||||
-#
|
||||
-# This file has the format :
|
||||
-# regex content-type icon content-encoding transfer-mode
|
||||
-#-----------------------------------------------------------------------------------
|
||||
-#
|
||||
-#
|
||||
-# Content-Encodings are taken from section 3.1 of RFC2068 (HTTP/1.1)
|
||||
-#
|
||||
-#
|
||||
-# This file has the format :
|
||||
-#
|
||||
-# regexp content-type icon encoding mode actions
|
||||
-#--------------------------------------------------------------------------------------------------------
|
||||
\.gif$ image/gif silk/image.png - image +download
|
||||
\.mime$ www/mime silk/page_white_text.png - ascii +download
|
||||
^internal-dirup$ - silk/arrow_up.png - -
|
||||
@@ -190,6 +174,4 @@ README text/plain silk/information.pn
|
||||
@@ -191,6 +174,4 @@ README text/plain silk/information.pn
|
||||
\.xml$ text/xml silk/page_world.png - ascii +download
|
||||
\.xsl$ text/xml silk/layout.png - ascii +download
|
||||
\.xyz$ chemical/x-xyz silk/chart_line.png - image +download
|
||||
-
|
||||
-#
|
||||
-# the default
|
||||
. text/plain silk/bullet_red.png - image +download +view
|
||||
|
|
Loading…
Reference in a new issue