coova-chilli: update to 1.6
Remove usptreamed patches. Switch to AUTORELEASE for simplicity. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
9543f72c77
commit
c05077a499
4 changed files with 3 additions and 90 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=coova-chilli
|
PKG_NAME:=coova-chilli
|
||||||
PKG_VERSION:=1.5
|
PKG_VERSION:=1.6
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/coova/coova-chilli/tar.gz/$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/coova/coova-chilli/tar.gz/$(PKG_VERSION)?
|
||||||
PKG_HASH:=75e15fd00a870b8a95df1440977c688a05a109f90b57bf679b931101d427d0fb
|
PKG_HASH:=26b2bead6fd9c18eb736fb0a0f8709922de4e4fedee1122193f82706eb2b9305
|
||||||
|
|
||||||
PKG_MAINTAINER:=Jaehoon You <teslamint@gmail.com>
|
PKG_MAINTAINER:=Jaehoon You <teslamint@gmail.com>
|
||||||
PKG_LICENSE:=GPL-2.0-or-later
|
PKG_LICENSE:=GPL-2.0-or-later
|
||||||
|
|
|
@ -1,53 +0,0 @@
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -397,7 +397,7 @@ AC_ARG_WITH([cyassl],
|
|
||||||
[AS_HELP_STRING([--with-cyassl], [enable support for cyassl])],[],[with_cyassl=no])
|
|
||||||
|
|
||||||
AS_IF([test x"$with_cyassl" != xno],
|
|
||||||
- [AC_CHECK_LIB([cyassl], [CyaSSL_Init],
|
|
||||||
+ [AC_CHECK_LIB([cyassl], [wolfSSL_Init],
|
|
||||||
[AC_SUBST([LIBSSL], ["-lcyassl"])
|
|
||||||
AC_DEFINE([HAVE_CYASSL], [1],
|
|
||||||
[Define if you have cyassl])
|
|
||||||
--- a/src/ippool.c
|
|
||||||
+++ b/src/ippool.c
|
|
||||||
@@ -35,6 +35,7 @@ int ippool_print(int fd, struct ippool_t
|
|
||||||
char * sep = "-- %-15s ------------------------------------------------------------\n";
|
|
||||||
|
|
||||||
#define ERR 0
|
|
||||||
+#undef USED /* defined in <wolfssl/wolfcrypt/integer.h> */
|
|
||||||
#define USED 1
|
|
||||||
#define FREE 2
|
|
||||||
#define LIST 3
|
|
||||||
--- a/src/md5.h
|
|
||||||
+++ b/src/md5.h
|
|
||||||
@@ -35,7 +35,6 @@
|
|
||||||
#define MD5Update MD5_Update
|
|
||||||
#define MD5Final MD5_Final
|
|
||||||
|
|
||||||
-typedef struct CYASSL_MD5_CTX MD5_CTX;
|
|
||||||
#else
|
|
||||||
|
|
||||||
struct MD5Context {
|
|
||||||
--- a/src/ssl.c
|
|
||||||
+++ b/src/ssl.c
|
|
||||||
@@ -131,7 +131,7 @@ _openssl_env_init(openssl_env *env, char
|
|
||||||
*/
|
|
||||||
const long options = SSL_OP_NO_SSLv2 | SSL_OP_NO_SSLv3 | SSL_OP_NO_COMPRESSION;
|
|
||||||
env->meth = SSLv23_method();
|
|
||||||
- env->ctx = SSL_CTX_new(env->meth);
|
|
||||||
+ env->ctx = SSL_CTX_new((void *)env->meth);
|
|
||||||
SSL_CTX_set_options(env->ctx, options);
|
|
||||||
if (_options.sslciphers) {
|
|
||||||
SSL_CTX_set_cipher_list(env->ctx, _options.sslciphers);
|
|
||||||
--- a/src/ssl.h
|
|
||||||
+++ b/src/ssl.h
|
|
||||||
@@ -48,6 +48,8 @@ typedef struct {
|
|
||||||
#include <time.h>
|
|
||||||
#include <string.h>
|
|
||||||
|
|
||||||
+#define OPENSSL_NO_ENGINE
|
|
||||||
+#include <cyassl/options.h>
|
|
||||||
#include <cyassl/ssl.h>
|
|
||||||
#include <cyassl/openssl/bio.h>
|
|
||||||
#include <cyassl/openssl/crypto.h>
|
|
|
@ -1,23 +0,0 @@
|
||||||
From 196b783b5ea7f8d6cf57ddbd41dc1881ef47a1c4 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rosen Penev <rosenp@gmail.com>
|
|
||||||
Date: Wed, 11 Dec 2019 19:33:58 -0800
|
|
||||||
Subject: [PATCH] system.h: Fix compilation with kernel 4.19 + musl
|
|
||||||
|
|
||||||
<linux/netlink.h> includes <linux/sysinfo.h> , which redefines struct sysinfo, leading to an error.
|
|
||||||
Define the linux header as included to solve compilation.
|
|
||||||
|
|
||||||
Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
|
||||||
---
|
|
||||||
src/system.h | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
--- a/src/system.h
|
|
||||||
+++ b/src/system.h
|
|
||||||
@@ -114,6 +114,7 @@
|
|
||||||
|
|
||||||
#ifdef HAVE_SYS_SYSINFO_H
|
|
||||||
#include <sys/sysinfo.h>
|
|
||||||
+#define _LINUX_SYSINFO_H
|
|
||||||
#else
|
|
||||||
#ifdef HAVE_LINUX_SYSINFO_H
|
|
||||||
#define _LINUX_KERNEL_H
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -2,7 +2,7 @@
|
|
||||||
# Process this file with autoconf to produce a configure script.
|
|
||||||
|
|
||||||
AC_PREREQ([2.59])
|
|
||||||
-AC_INIT([coova-chilli],[1.4],[https://github.com/coova/coova-chilli/issues])
|
|
||||||
+AC_INIT([coova-chilli],[1.5],[https://github.com/coova/coova-chilli/issues])
|
|
||||||
AC_CONFIG_SRCDIR([src/chilli.c])
|
|
||||||
|
|
||||||
AM_INIT_AUTOMAKE
|
|
Loading…
Reference in a new issue