miniupnpd: update to 2.1.20191006
Removed upstreamed patch:
100-build-on-OpenWrt.patch
Signed-off-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn>
(cherry picked from commit fcf72ceec4
)
This commit is contained in:
parent
66363912db
commit
c02c42849e
3 changed files with 5 additions and 63 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=miniupnpd
|
||||
PKG_VERSION:=2.1.20190408
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=2.1.20191006
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_URL:=https://miniupnp.tuxfamily.org/files
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_HASH:=4175d588f600e2877503c781c5d75320dfce572669fcab7604434b07ec5c0d5d
|
||||
PKG_HASH:=218fad7af31f3c22fb4c9db28a55a2a8b5067d41f5b38f52008a057a00d2206d
|
||||
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
|
|
@ -1,58 +0,0 @@
|
|||
--- a/genconfig.sh
|
||||
+++ b/genconfig.sh
|
||||
@@ -379,12 +379,19 @@ case $FW in
|
||||
esac
|
||||
|
||||
# UUID API
|
||||
-if grep uuid_create /usr/include/uuid.h > /dev/null 2>&1 ; then
|
||||
- echo "#define BSD_UUID" >> ${CONFIGFILE}
|
||||
-fi
|
||||
-if grep uuid_generate /usr/include/uuid/uuid.h > /dev/null 2>&1 ; then
|
||||
- echo "#define LIB_UUID" >> ${CONFIGFILE}
|
||||
-fi
|
||||
+case $OS_NAME in
|
||||
+ OpenWRT)
|
||||
+ echo "#define LIB_UUID" >> ${CONFIGFILE}
|
||||
+ ;;
|
||||
+ *)
|
||||
+ if grep uuid_create /usr/include/uuid.h > /dev/null 2>&1 ; then
|
||||
+ echo "#define BSD_UUID" >> ${CONFIGFILE}
|
||||
+ fi
|
||||
+ if grep uuid_generate /usr/include/uuid/uuid.h > /dev/null 2>&1 ; then
|
||||
+ echo "#define LIB_UUID" >> ${CONFIGFILE}
|
||||
+ fi
|
||||
+ ;;
|
||||
+esac
|
||||
|
||||
# set V6SOCKETS_ARE_V6ONLY to 0 if it was not set above
|
||||
if [ -z "$V6SOCKETS_ARE_V6ONLY" ] ; then
|
||||
--- a/Makefile.linux
|
||||
+++ b/Makefile.linux
|
||||
@@ -77,7 +77,10 @@ CPPFLAGS += -DIPTABLES_143
|
||||
endif
|
||||
|
||||
CFLAGS += $(shell $(PKG_CONFIG) --cflags libiptc)
|
||||
+#OpenWrt packager passes correct libraries
|
||||
+ifeq ($(TARGET_OPENWRT),)
|
||||
LDLIBS += $(shell $(PKG_CONFIG) --static --libs-only-l libiptc)
|
||||
+endif
|
||||
LDFLAGS += $(shell $(PKG_CONFIG) --libs-only-L libiptc)
|
||||
LDFLAGS += $(shell $(PKG_CONFIG) --libs-only-other libiptc)
|
||||
else
|
||||
@@ -157,6 +160,8 @@ LDLIBS += $(shell $(PKG_CONFIG) --static
|
||||
LDLIBS += $(shell $(PKG_CONFIG) --static --libs-only-l libnetfilter_conntrack)
|
||||
endif # ($(TEST),1)
|
||||
|
||||
+# OpenWrt packager disables https server for IGD v2 and hardcodes libuuid support
|
||||
+ifeq ($(TARGET_OPENWRT),)
|
||||
LDLIBS += $(shell $(PKG_CONFIG) --static --libs-only-l libssl)
|
||||
|
||||
TEST := $(shell $(PKG_CONFIG) --exists uuid && echo 1)
|
||||
@@ -165,6 +170,7 @@ LDLIBS += $(shell $(PKG_CONFIG) --static
|
||||
else
|
||||
$(info please install uuid-dev package / libuuid)
|
||||
endif # ($(TEST),1)
|
||||
+endif # ($(TARGET_OPENWRT,)
|
||||
|
||||
GLIBC_VERSION := $(shell ldd --version | head -n 1 | sed 's/^.* //')
|
||||
GLIBC_VERSION_MAJOR = $(shell echo $(GLIBC_VERSION) | cut -f 1 -d . )
|
|
@ -1,7 +1,7 @@
|
|||
--- a/Makefile.linux
|
||||
+++ b/Makefile.linux
|
||||
@@ -23,16 +23,16 @@
|
||||
#
|
||||
@@ -24,16 +24,16 @@
|
||||
CONFIG_OPTIONS += --firewall=iptables
|
||||
#CFLAGS = -O -g -DDEBUG
|
||||
CFLAGS ?= -Os
|
||||
-CFLAGS += -fno-strict-aliasing
|
||||
|
|
Loading…
Reference in a new issue