zile: Remove unecessary dependence on libncurses (non-w) version
Signed-off-by: Ted Hess <thess@kitschensync.net>
This commit is contained in:
parent
7aa4b19f97
commit
befa2ce3e2
3 changed files with 31 additions and 3 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=zile
|
||||
PKG_VERSION:=2.3.24
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@GNU/zile
|
||||
|
@ -22,8 +22,6 @@ PKG_LICENSE_FILES:=COPYING
|
|||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
|
||||
PKG_BUILD_DEPENDS += libncurses
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/zile
|
||||
|
@ -46,6 +44,10 @@ CONFIGURE_VARS += \
|
|||
gl_cv_warn__Wmudflap=no \
|
||||
gl_cv_warn__fmudflap=no
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--with-ncursesw \
|
||||
|
||||
|
||||
define Package/zile/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
--- a/m4/ax_with_curses.m4
|
||||
+++ b/m4/ax_with_curses.m4
|
||||
@@ -72,7 +72,7 @@ AC_DEFUN([AX_WITH_CURSES],
|
||||
AC_CACHE_CHECK([for working ncursesw], ax_cv_ncursesw,
|
||||
[LIBS="$ax_save_LIBS -lncursesw"
|
||||
AC_TRY_LINK(
|
||||
- [#include <ncurses.h>],
|
||||
+ [#include <ncursesw/ncurses.h>],
|
||||
[chtype a; int b=A_STANDOUT, c=KEY_LEFT; initscr(); ],
|
||||
ax_cv_ncursesw=yes, ax_cv_ncursesw=no)])
|
||||
if test "$ax_cv_ncursesw" = yes
|
15
utils/zile/patches/020-build_with_ncursesw.patch
Normal file
15
utils/zile/patches/020-build_with_ncursesw.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- a/src/term_curses.c
|
||||
+++ b/src/term_curses.c
|
||||
@@ -23,7 +23,11 @@
|
||||
|
||||
#include <stdlib.h>
|
||||
#ifdef HAVE_NCURSES_H
|
||||
-#include <ncurses.h>
|
||||
+# ifdef HAVE_NCURSESW
|
||||
+# include <ncursesw/ncurses.h>
|
||||
+# else
|
||||
+# include <ncurses.h>
|
||||
+# endif
|
||||
#else
|
||||
#include <curses.h>
|
||||
#endif
|
Loading…
Reference in a new issue