gnunet: update to version 0.19.4
v0.19.4: - No changes v0.19.3: - We now detect MySQL's strange, version-dependent my_bool type on configure. - Add pkg-config definitions for gnunet messenger. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
7eaa2cd284
commit
bef5da553f
2 changed files with 2 additions and 20 deletions
|
@ -2,11 +2,11 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=gnunet
|
||||
|
||||
PKG_VERSION:=0.19.2
|
||||
PKG_VERSION:=0.19.4
|
||||
PKG_RELEASE:=1
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@GNU/gnunet
|
||||
PKG_HASH:=86034d92ebf8f6623dad95f1031ded1466e064b96ffac9d3e9d47229ac2c22ff
|
||||
PKG_HASH:=00a63df408d5987f5ba9a50441f2a77182bd9fb32f1e302ae563ac94e7ac009b
|
||||
|
||||
PKG_LICENSE:=AGPL-3.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
--- a/src/include/gnunet_common.h
|
||||
+++ b/src/include/gnunet_common.h
|
||||
@@ -164,7 +164,6 @@ enum GNUNET_GenericReturnValue
|
||||
* Endian operations
|
||||
*/
|
||||
|
||||
-#if __BYTE_ORDER == __LITTLE_ENDIAN
|
||||
#if defined(bswap_16) || defined(bswap_32) || defined(bswap_64)
|
||||
#define BYTE_SWAP_16(x) bswap_16 (x)
|
||||
#define BYTE_SWAP_32(x) bswap_32 (x)
|
||||
@@ -184,6 +183,7 @@ enum GNUNET_GenericReturnValue
|
||||
56))
|
||||
#endif
|
||||
|
||||
+#if __BYTE_ORDER == __LITTLE_ENDIAN
|
||||
#define GNUNET_htobe16(x) BYTE_SWAP_16 (x)
|
||||
#define GNUNET_htole16(x) (x)
|
||||
#define GNUNET_be16toh(x) BYTE_SWAP_16 (x)
|
Loading…
Reference in a new issue