luaposix: remove deprecated/compatibility modules, remove dependency on luabitop
Signed-off-by: Maxim Storchak <m.storchak@gmail.com>
This commit is contained in:
parent
fd2e9f0750
commit
be4158484b
2 changed files with 22 additions and 3 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=luaposix
|
||||
PKG_VERSION:=v33.2.1
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_SOURCE:=release-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/luaposix/luaposix/archive/
|
||||
|
@ -29,7 +29,7 @@ define Package/luaposix
|
|||
CATEGORY:=Languages
|
||||
TITLE:=luaposix
|
||||
URL:=http://luaforge.net/projects/luaposix/
|
||||
DEPENDS:=+lua +librt +luabitop
|
||||
DEPENDS:=+lua +librt
|
||||
PKG_BUILD_DEPENDS:=+lua/host
|
||||
endef
|
||||
|
||||
|
@ -53,7 +53,6 @@ define Package/luaposix/install
|
|||
$(INSTALL_DIR) $(1)/usr/lib/lua/posix
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ext/posix/.libs/posix.so $(1)/usr/lib/lua
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/posix.lua $(1)/usr/lib/lua
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/posix/*.lua $(1)/usr/lib/lua/posix
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,luaposix))
|
||||
|
|
20
lang/luaposix/patches/102-disable-compat-deprecated.diff
Normal file
20
lang/luaposix/patches/102-disable-compat-deprecated.diff
Normal file
|
@ -0,0 +1,20 @@
|
|||
diff --git a/lib/posix.lua.in b/lib/posix.lua.in
|
||||
index 17ef39a..a248d9b 100644
|
||||
--- a/lib/posix.lua.in
|
||||
+++ b/lib/posix.lua.in
|
||||
@@ -35,15 +35,6 @@ for _, sub in ipairs {
|
||||
end
|
||||
end
|
||||
|
||||
-
|
||||
--- Inject deprecated APIs (overwriting submodules) for backwards compatibility.
|
||||
-for k, v in pairs (require "posix.deprecated") do
|
||||
- M[k] = v
|
||||
-end
|
||||
-for k, v in pairs (require "posix.compat") do
|
||||
- M[k] = v
|
||||
-end
|
||||
-
|
||||
M.version = "posix for " .. _VERSION .. " / @PACKAGE_STRING@"
|
||||
|
||||
|
Loading…
Reference in a new issue