redis: fix compilation for uClibc
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
This commit is contained in:
parent
4b0eaf9471
commit
be17ecea22
2 changed files with 26 additions and 1 deletions
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=redis
|
||||
PKG_VERSION:=5.0.5
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE_URL:=http://download.redis.io/releases/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
|
|
25
libs/redis/patches/030-fix-uclibc-compilation.patch
Normal file
25
libs/redis/patches/030-fix-uclibc-compilation.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
--- a/src/config.h
|
||||
+++ b/src/config.h
|
||||
@@ -30,6 +30,10 @@
|
||||
#ifndef __CONFIG_H
|
||||
#define __CONFIG_H
|
||||
|
||||
+#if defined(__unix) || defined(__linux__)
|
||||
+#include <features.h>
|
||||
+#endif
|
||||
+
|
||||
#ifdef __APPLE__
|
||||
#include <AvailabilityMacros.h>
|
||||
#endif
|
||||
@@ -62,9 +66,9 @@
|
||||
#endif
|
||||
|
||||
/* Test for backtrace() */
|
||||
-#if defined(__APPLE__) || (defined(__linux__) && defined(__GLIBC__)) || \
|
||||
+#if (defined(__APPLE__) || (defined(__linux__) && defined(__GLIBC__)) || \
|
||||
defined(__FreeBSD__) || (defined(__OpenBSD__) && defined(USE_BACKTRACE))\
|
||||
- || defined(__DragonFly__)
|
||||
+ || defined(__DragonFly__)) && !defined(__UCLIBC__)
|
||||
#define HAVE_BACKTRACE 1
|
||||
#endif
|
||||
|
Loading…
Reference in a new issue