icu: update to 65.1
Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
(cherry-picked from 23adefbb7b
)
This commit is contained in:
parent
d1f0d0f2cc
commit
bdbdd1d749
3 changed files with 5 additions and 51 deletions
|
@ -8,16 +8,16 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=icu4c
|
||||
MAJOR_VERSION:=64
|
||||
MINOR_VERSION:=2
|
||||
MAJOR_VERSION:=65
|
||||
MINOR_VERSION:=1
|
||||
PKG_VERSION:=$(MAJOR_VERSION).$(MINOR_VERSION)
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(MAJOR_VERSION)_$(MINOR_VERSION)-src.tgz
|
||||
PKG_SOURCE_URL:=https://github.com/unicode-org/icu/releases/download/release-$(MAJOR_VERSION)-$(MINOR_VERSION)
|
||||
PKG_HASH:=627d5d8478e6d96fc8c90fed4851239079a561a6a8b9e48b0892f24e82d31d6c
|
||||
PKG_HASH:=53e37466b3d6d6d01ead029e3567d873a43a5d1c668ed2278e253b683136d948
|
||||
|
||||
PKG_LICENSE:=ICU-1.8.1+
|
||||
PKG_LICENSE:=ICU
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
PKG_CPE_ID:=cpe:/a:icu-project:international_components_for_unicode
|
||||
|
||||
|
@ -25,7 +25,6 @@ PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>
|
|||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
PKG_BUILD_DEPENDS:=icu/host
|
||||
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
From cb5cf996d123014a2420c853c4db60e4500973b1 Mon Sep 17 00:00:00 2001
|
||||
From: Rosen Penev <rosenp@gmail.com>
|
||||
Date: Mon, 1 Apr 2019 04:52:32 -0700
|
||||
Subject: [PATCH] Add big endian ARM support (#92)
|
||||
|
||||
This fixes compilation on such platforms.
|
||||
---
|
||||
double-conversion/utils.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/source/i18n/double-conversion-utils.h b/source/i18n/double-conversion-utils.h
|
||||
index 1e44fca..b715c65 100644
|
||||
--- a/18n/double-conversion-utils.h
|
||||
+++ b/i18n/double-conversion-utils.h
|
||||
@@ -99,7 +99,7 @@ int main(int argc, char** argv) {
|
||||
defined(_POWER) || defined(_ARCH_PPC) || defined(_ARCH_PPC64) || \
|
||||
defined(__sparc__) || defined(__sparc) || defined(__s390__) || \
|
||||
defined(__SH4__) || defined(__alpha__) || \
|
||||
- defined(_MIPS_ARCH_MIPS32R2) || \
|
||||
+ defined(_MIPS_ARCH_MIPS32R2) || defined(__ARMEB__) || \
|
||||
defined(__AARCH64EL__) || defined(__aarch64__) || defined(__AARCH64EB__) || \
|
||||
defined(__riscv) || \
|
||||
defined(__or1k__) || defined(__arc__) || \
|
|
@ -1,22 +0,0 @@
|
|||
--- a/i18n/decimfmt.cpp
|
||||
+++ b/i18n/decimfmt.cpp
|
||||
@@ -1812,7 +1812,7 @@ bool DecimalFormat::fastFormatDouble(double input, UnicodeString& output) const
|
||||
return false;
|
||||
}
|
||||
if (std::isnan(input)
|
||||
- || std::trunc(input) != input
|
||||
+ || trunc(input) != input
|
||||
|| input <= INT32_MIN
|
||||
|| input > INT32_MAX) {
|
||||
return false;
|
||||
--- a/i18n/number_decimalquantity.cpp
|
||||
+++ b/i18n/number_decimalquantity.cpp
|
||||
@@ -446,7 +446,7 @@ void DecimalQuantity::_setToDoubleFast(double n) {
|
||||
for (; i <= -22; i += 22) n /= 1e22;
|
||||
n /= DOUBLE_MULTIPLIERS[-i];
|
||||
}
|
||||
- auto result = static_cast<int64_t>(std::round(n));
|
||||
+ auto result = static_cast<int64_t>(round(n));
|
||||
if (result != 0) {
|
||||
_setToLong(result);
|
||||
scale -= fracLength;
|
Loading…
Reference in a new issue