libsoup: fix compilation with libml2 1.12
Needs a different header. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
ee4573cd42
commit
bdb94243f6
2 changed files with 23 additions and 1 deletions
|
@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libsoup
|
PKG_NAME:=libsoup
|
||||||
PKG_VERSION:=2.74.3
|
PKG_VERSION:=2.74.3
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@GNOME/libsoup/$(basename $(PKG_VERSION))
|
PKG_SOURCE_URL:=@GNOME/libsoup/$(basename $(PKG_VERSION))
|
||||||
|
|
22
libs/libsoup/patches/010-libxml-1.12.patch
Normal file
22
libs/libsoup/patches/010-libxml-1.12.patch
Normal file
|
@ -0,0 +1,22 @@
|
||||||
|
--- a/libsoup/soup-xmlrpc-old.c
|
||||||
|
+++ b/libsoup/soup-xmlrpc-old.c
|
||||||
|
@@ -11,7 +11,7 @@
|
||||||
|
|
||||||
|
#include <string.h>
|
||||||
|
|
||||||
|
-#include <libxml/tree.h>
|
||||||
|
+#include <libxml/parser.h>
|
||||||
|
|
||||||
|
#include "soup-xmlrpc-old.h"
|
||||||
|
#include "soup.h"
|
||||||
|
--- a/libsoup/soup-xmlrpc.c
|
||||||
|
+++ b/libsoup/soup-xmlrpc.c
|
||||||
|
@@ -17,7 +17,7 @@
|
||||||
|
|
||||||
|
#include <string.h>
|
||||||
|
#include <errno.h>
|
||||||
|
-#include <libxml/tree.h>
|
||||||
|
+#include <libxml/parser.h>
|
||||||
|
#include "soup-xmlrpc.h"
|
||||||
|
#include "soup.h"
|
||||||
|
|
Loading…
Reference in a new issue