tvheadend: Fix compilation without OpenSSL deprecated APIs
Also switched to codeload for Makefile simplicity.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry-picked from 5033e594cc
)
This commit is contained in:
parent
59f7eb5e1f
commit
bd96e95e3f
2 changed files with 39 additions and 8 deletions
|
@ -9,15 +9,11 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=tvheadend
|
||||
PKG_VERSION:=4.0.10
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)
|
||||
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.xz
|
||||
PKG_MIRROR_HASH:=afe42bcf683e8576ca8ccd4755ea308f79195e92f7c30fc5961973e238f49105
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/tvheadend/tvheadend.git
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/tvheadend/tvheadend/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=f610e7d9f3bf6cff05cd73830a66ee0c74bc5291c4c9d08369364c4c681ebf23
|
||||
|
||||
PKG_LICENSE:=GPL-3.0
|
||||
PKG_LICENSE_FILES:=LICENSE.md
|
||||
|
|
35
multimedia/tvheadend/patches/010-openssl-deprecated.patch
Normal file
35
multimedia/tvheadend/patches/010-openssl-deprecated.patch
Normal file
|
@ -0,0 +1,35 @@
|
|||
--- a/src/main.c
|
||||
+++ b/src/main.c
|
||||
@@ -965,10 +965,12 @@ main(int argc, char **argv)
|
||||
sigprocmask(SIG_BLOCK, &set, NULL);
|
||||
trap_init(argv[0]);
|
||||
|
||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
|
||||
/* SSL library init */
|
||||
OPENSSL_config(NULL);
|
||||
SSL_load_error_strings();
|
||||
SSL_library_init();
|
||||
+#endif
|
||||
|
||||
/* Initialise configuration */
|
||||
notify_init();
|
||||
@@ -1159,8 +1161,11 @@ main(int argc, char **argv)
|
||||
#endif
|
||||
free(opt_satip_xml.str);
|
||||
|
||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
|
||||
/* OpenSSL - welcome to the "cleanup" hell */
|
||||
+#ifndef OPENSSL_NO_ENGINE
|
||||
ENGINE_cleanup();
|
||||
+#endif
|
||||
RAND_cleanup();
|
||||
CRYPTO_cleanup_all_ex_data();
|
||||
EVP_cleanup();
|
||||
@@ -1174,6 +1179,7 @@ main(int argc, char **argv)
|
||||
sk_SSL_COMP_free(SSL_COMP_get_compression_methods());
|
||||
#endif
|
||||
/* end of OpenSSL cleanup code */
|
||||
+#endif
|
||||
|
||||
#if ENABLE_DBUS_1
|
||||
extern void dbus_shutdown(void);
|
Loading…
Reference in a new issue