Merge pull request #15002 from plntyk/i2pd_fixup
I2pd: fix imagebuilder and startup
This commit is contained in:
commit
bc3ac134f6
3 changed files with 4 additions and 36 deletions
|
@ -9,12 +9,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=i2pd
|
PKG_NAME:=i2pd
|
||||||
PKG_VERSION:=2.35.0
|
PKG_VERSION:=2.36.0
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/PurpleI2P/i2pd/tar.gz/$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/PurpleI2P/i2pd/tar.gz/$(PKG_VERSION)?
|
||||||
PKG_HASH:=d041fd4e7a88ac168e76f66fdab40174ad093cdc13451cdbd0dd1216e5581f8a
|
PKG_HASH:=17b7309cbee41b991cf9480334495c5a049f709beb1b31fbfcb47de19c8462a3
|
||||||
|
|
||||||
PKG_MAINTAINER:=David Yang <mmyangfl@gmail.com>
|
PKG_MAINTAINER:=David Yang <mmyangfl@gmail.com>
|
||||||
PKG_LICENSE:=BSD-3-Clause
|
PKG_LICENSE:=BSD-3-Clause
|
||||||
|
|
|
@ -14,7 +14,6 @@ PIDFILE=/var/run/i2pd.pid
|
||||||
DATADIR=/var/lib/i2pd
|
DATADIR=/var/lib/i2pd
|
||||||
CONFFILE=/etc/i2pd/i2pd.conf
|
CONFFILE=/etc/i2pd/i2pd.conf
|
||||||
|
|
||||||
. /lib/functions.sh
|
|
||||||
|
|
||||||
|
|
||||||
i2pd_start() {
|
i2pd_start() {
|
||||||
|
@ -43,6 +42,7 @@ i2pd_start() {
|
||||||
## We need permissions
|
## We need permissions
|
||||||
touch "$PIDFILE"
|
touch "$PIDFILE"
|
||||||
chown "$USER:adm" "$PIDFILE"
|
chown "$USER:adm" "$PIDFILE"
|
||||||
|
chown "$USER:adm" "$CONFFILE"
|
||||||
|
|
||||||
procd_open_instance
|
procd_open_instance
|
||||||
procd_set_param command "$PROG" --service --conf="$CONFFILE" --pidfile "$PIDFILE"
|
procd_set_param command "$PROG" --service --conf="$CONFFILE" --pidfile "$PIDFILE"
|
||||||
|
|
|
@ -1,32 +0,0 @@
|
||||||
From ca3b8191510c1006d031d02c50edcf6b4f6a6e8f Mon Sep 17 00:00:00 2001
|
|
||||||
From: R4SAS <r4sas@i2pmail.org>
|
|
||||||
Date: Thu, 10 Dec 2020 18:32:41 +0300
|
|
||||||
Subject: [PATCH] [avx] check ig c++ target supports AVX
|
|
||||||
|
|
||||||
Signed-off-by: R4SAS <r4sas@i2pmail.org>
|
|
||||||
---
|
|
||||||
libi2pd/Crypto.cpp | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
--- a/libi2pd/Crypto.cpp
|
|
||||||
+++ b/libi2pd/Crypto.cpp
|
|
||||||
@@ -638,7 +638,7 @@ namespace crypto
|
|
||||||
{
|
|
||||||
uint64_t buf[256];
|
|
||||||
uint64_t hash[12]; // 96 bytes
|
|
||||||
-#if defined(__x86_64__) || defined(__i386__)
|
|
||||||
+#if (defined(__x86_64__) || defined(__i386__)) && defined(__AVX__) // not all X86 targets supports AVX (like old Pentium, see #1600)
|
|
||||||
if(i2p::cpu::avx)
|
|
||||||
{
|
|
||||||
__asm__
|
|
||||||
--- a/libi2pd/Identity.cpp
|
|
||||||
+++ b/libi2pd/Identity.cpp
|
|
||||||
@@ -828,7 +828,7 @@ namespace data
|
|
||||||
XORMetric operator^(const IdentHash& key1, const IdentHash& key2)
|
|
||||||
{
|
|
||||||
XORMetric m;
|
|
||||||
-#if defined(__x86_64__) || defined(__i386__)
|
|
||||||
+#if (defined(__x86_64__) || defined(__i386__)) && defined(__AVX__) // not all X86 targets supports AVX (like old Pentium, see #1600)
|
|
||||||
if(i2p::cpu::avx)
|
|
||||||
{
|
|
||||||
__asm__
|
|
Loading…
Reference in a new issue