libcap: fix build failure
Building is failing during the test compilation due to static compilation. Disable tests as they are not being used. Signed-off-by: Paulo Machado <pffmachado@yahoo.com>
This commit is contained in:
parent
9d2d042115
commit
bb34fcebe5
2 changed files with 10 additions and 11 deletions
10
libs/libcap/patches/300-disable-tests.patch
Normal file
10
libs/libcap/patches/300-disable-tests.patch
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -16,7 +16,6 @@ endif
|
||||||
|
ifeq ($(GOLANG),yes)
|
||||||
|
$(MAKE) -C go $@
|
||||||
|
endif
|
||||||
|
- $(MAKE) -C tests $@
|
||||||
|
$(MAKE) -C progs $@
|
||||||
|
$(MAKE) -C doc $@
|
||||||
|
$(MAKE) -C kdebug $@
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/tests/Makefile
|
|
||||||
+++ b/tests/Makefile
|
|
||||||
@@ -32,7 +32,7 @@ run_libcap_psx_test: libcap_psx_test
|
|
||||||
./libcap_psx_test
|
|
||||||
|
|
||||||
libcap_psx_test: libcap_psx_test.c $(DEPS)
|
|
||||||
- $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LIBCAPLIB) $(LIBPSXLIB) -Wl,-wrap,pthread_create --static
|
|
||||||
+ $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LIBCAPLIB) $(LIBPSXLIB) -Wl,-wrap,pthread_create
|
|
||||||
|
|
||||||
run_libcap_launch_test: libcap_launch_test libcap_psx_launch_test noop
|
|
||||||
sudo ./libcap_launch_test
|
|
Loading…
Reference in a new issue