libshout: add openssl 1.1.0 compatibility
Avoid calling deprecated and unnecessary library initialization functions with openssl >= 1.1.0. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
This commit is contained in:
parent
d9e9b59159
commit
bb31b90d73
2 changed files with 16 additions and 1 deletions
|
@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libshout
|
PKG_NAME:=libshout
|
||||||
PKG_VERSION:=2.4.1
|
PKG_VERSION:=2.4.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
|
15
libs/libshout/patches/150-openssl-1.1.patch
Normal file
15
libs/libshout/patches/150-openssl-1.1.patch
Normal file
|
@ -0,0 +1,15 @@
|
||||||
|
--- a/src/tls.c
|
||||||
|
+++ b/src/tls.c
|
||||||
|
@@ -63,10 +63,12 @@ static inline int tls_setup(shout_tls_t
|
||||||
|
{
|
||||||
|
SSL_METHOD *meth;
|
||||||
|
|
||||||
|
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
|
||||||
|
SSL_library_init();
|
||||||
|
SSL_load_error_strings();
|
||||||
|
SSLeay_add_all_algorithms();
|
||||||
|
SSLeay_add_ssl_algorithms();
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
meth = TLSv1_client_method();
|
||||||
|
if (!meth)
|
Loading…
Reference in a new issue