boost: Fix compilation with uClibc-ng
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry-picked from 053faa31e5
)
This commit is contained in:
parent
ad26261e18
commit
bb1882d294
2 changed files with 44 additions and 1 deletions
|
@ -13,7 +13,7 @@ include $(TOPDIR)/rules.mk
|
|||
PKG_NAME:=boost
|
||||
PKG_VERSION:=1.68.0
|
||||
PKG_SOURCE_VERSION:=1_68_0
|
||||
PKG_RELEASE:=5
|
||||
PKG_RELEASE:=6
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://dl.bintray.com/boostorg/release/$(PKG_VERSION)/source/
|
||||
|
|
43
libs/boost/patches/010-uclibc-ng.patch
Normal file
43
libs/boost/patches/010-uclibc-ng.patch
Normal file
|
@ -0,0 +1,43 @@
|
|||
--- a/boost/asio/detail/impl/eventfd_select_interrupter.ipp
|
||||
+++ b/boost/asio/detail/impl/eventfd_select_interrupter.ipp
|
||||
@@ -23,11 +23,11 @@
|
||||
#include <sys/stat.h>
|
||||
#include <sys/types.h>
|
||||
#include <fcntl.h>
|
||||
-#if __GLIBC__ == 2 && __GLIBC_MINOR__ < 8
|
||||
+#if __GLIBC__ == 2 && __GLIBC_MINOR__ < 2
|
||||
# include <asm/unistd.h>
|
||||
-#else // __GLIBC__ == 2 && __GLIBC_MINOR__ < 8
|
||||
+#else // __GLIBC__ == 2 && __GLIBC_MINOR__ < 2
|
||||
# include <sys/eventfd.h>
|
||||
-#endif // __GLIBC__ == 2 && __GLIBC_MINOR__ < 8
|
||||
+#endif // __GLIBC__ == 2 && __GLIBC_MINOR__ < 2
|
||||
#include <boost/asio/detail/cstdint.hpp>
|
||||
#include <boost/asio/detail/eventfd_select_interrupter.hpp>
|
||||
#include <boost/asio/detail/throw_error.hpp>
|
||||
@@ -46,14 +46,14 @@ eventfd_select_interrupter::eventfd_select_interrupter()
|
||||
|
||||
void eventfd_select_interrupter::open_descriptors()
|
||||
{
|
||||
-#if __GLIBC__ == 2 && __GLIBC_MINOR__ < 8
|
||||
+#if __GLIBC__ == 2 && __GLIBC_MINOR__ < 2
|
||||
write_descriptor_ = read_descriptor_ = syscall(__NR_eventfd, 0);
|
||||
if (read_descriptor_ != -1)
|
||||
{
|
||||
::fcntl(read_descriptor_, F_SETFL, O_NONBLOCK);
|
||||
::fcntl(read_descriptor_, F_SETFD, FD_CLOEXEC);
|
||||
}
|
||||
-#else // __GLIBC__ == 2 && __GLIBC_MINOR__ < 8
|
||||
+#else // __GLIBC__ == 2 && __GLIBC_MINOR__ < 2
|
||||
# if defined(EFD_CLOEXEC) && defined(EFD_NONBLOCK)
|
||||
write_descriptor_ = read_descriptor_ =
|
||||
::eventfd(0, EFD_CLOEXEC | EFD_NONBLOCK);
|
||||
@@ -70,7 +70,7 @@ void eventfd_select_interrupter::open_descriptors()
|
||||
::fcntl(read_descriptor_, F_SETFD, FD_CLOEXEC);
|
||||
}
|
||||
}
|
||||
-#endif // __GLIBC__ == 2 && __GLIBC_MINOR__ < 8
|
||||
+#endif // __GLIBC__ == 2 && __GLIBC_MINOR__ < 2
|
||||
|
||||
if (read_descriptor_ == -1)
|
||||
{
|
Loading…
Reference in a new issue