From 9e011b2fc814b63aae2a71ad8ee1351edb325a92 Mon Sep 17 00:00:00 2001
From: Jan Pavlinec <jan.pavlinec@nic.cz>
Date: Wed, 3 Mar 2021 10:13:15 +0100
Subject: [PATCH 1/4] python-engineio: add new package

Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
---
 lang/python/python-engineio/Makefile | 45 ++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)
 create mode 100644 lang/python/python-engineio/Makefile

diff --git a/lang/python/python-engineio/Makefile b/lang/python/python-engineio/Makefile
new file mode 100644
index 000000000..ad3196ac0
--- /dev/null
+++ b/lang/python/python-engineio/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2021 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-engineio
+PKG_VERSION:=4.0.1
+PKG_RELEASE:=1
+
+PYPI_NAME:=python-engineio
+PKG_HASH:=bb575c1a3512b4b5d4706f3071d5cc36e592459e99a47d9a4b7faabeba941377
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-engineio
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=Engine.IO server
+  URL:=https://github.com/miguelgrinberg/python-engineio
+  DEPENDS:= \
+	+python3-light \
+	+python3-asyncio \
+	+python3-logging \
+	+python3-openssl \
+	+python3-urllib
+endef
+
+define Package/python3-engineio/description
+  Python implementation of the Engine.IO realtime client and server.
+endef
+
+$(eval $(call Py3Package,python3-engineio))
+$(eval $(call BuildPackage,python3-engineio))
+$(eval $(call BuildPackage,python3-engineio-src))

From decbd7b43a952dcce765ab6e5bbf8da4259453db Mon Sep 17 00:00:00 2001
From: Jan Pavlinec <jan.pavlinec@nic.cz>
Date: Wed, 3 Mar 2021 10:36:33 +0100
Subject: [PATCH 2/4] python-socketio: add new package

Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
---
 lang/python/python-socketio/Makefile | 46 ++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)
 create mode 100644 lang/python/python-socketio/Makefile

diff --git a/lang/python/python-socketio/Makefile b/lang/python/python-socketio/Makefile
new file mode 100644
index 000000000..b80eaaaae
--- /dev/null
+++ b/lang/python/python-socketio/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2021 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-socketio
+PKG_VERSION:=5.1.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=python-socketio
+PKG_HASH:=338cc29abb6f3ca14c88f1f8d05ed27c690df4648f62062b299f92625bbf7093
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-socketio
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=Socket.IO server and client
+  URL:=https://github.com/miguelgrinberg/python-socketio
+  DEPENDS:= \
+	+python3-light \
+	+python3-bidict \
+	+python3-engineio \
+	+python3-asyncio \
+	+python3-logging \
+	+python3-urllib
+endef
+
+define Package/python3-socketio/description
+  Python implementation of the Socket.IO realtime client and server.
+endef
+
+$(eval $(call Py3Package,python3-socketio))
+$(eval $(call BuildPackage,python3-socketio))
+$(eval $(call BuildPackage,python3-socketio-src))

From ae0556e6a53f85948448f04d1bc22884906f727e Mon Sep 17 00:00:00 2001
From: Jan Pavlinec <jan.pavlinec@nic.cz>
Date: Wed, 3 Mar 2021 12:51:13 +0100
Subject: [PATCH 3/4] python-bidict: add new package

Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
---
 lang/python/python-bidict/Makefile | 43 ++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
 create mode 100644 lang/python/python-bidict/Makefile

diff --git a/lang/python/python-bidict/Makefile b/lang/python/python-bidict/Makefile
new file mode 100644
index 000000000..78066a53a
--- /dev/null
+++ b/lang/python/python-bidict/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2021 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-bidict
+PKG_VERSION:=0.21.2
+PKG_RELEASE:=1
+
+PYPI_NAME:=bidict
+PKG_HASH:=4fa46f7ff96dc244abfc437383d987404ae861df797e2fd5b190e233c302be09
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MPL-2.0
+PKG_LICENSE_FILES:=LICENSE
+
+HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=setuptools-scm
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-bidict
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=The bidirectional mapping library
+  URL:=https://github.com/jab/bidict
+  DEPENDS:= \
+	+python3-light
+endef
+
+define Package/python3-bidict/description
+  The bidirectional mapping library for Python.
+endef
+
+$(eval $(call Py3Package,python3-bidict))
+$(eval $(call BuildPackage,python3-bidict))
+$(eval $(call BuildPackage,python3-bidict-src))

From 8133922a029adbc0cec32cc64c4cbbb16cf82da5 Mon Sep 17 00:00:00 2001
From: Jan Pavlinec <jan.pavlinec@nic.cz>
Date: Wed, 3 Mar 2021 13:51:31 +0100
Subject: [PATCH 4/4] python-flask-socketio: add new package

Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
---
 lang/python/python-flask-socketio/Makefile | 44 ++++++++++++++++++++++
 1 file changed, 44 insertions(+)
 create mode 100644 lang/python/python-flask-socketio/Makefile

diff --git a/lang/python/python-flask-socketio/Makefile b/lang/python/python-flask-socketio/Makefile
new file mode 100644
index 000000000..945d57aa3
--- /dev/null
+++ b/lang/python/python-flask-socketio/Makefile
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2021 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-flask-socketio
+PKG_VERSION:=5.0.1
+PKG_RELEASE:=1
+
+PYPI_NAME:=Flask-SocketIO
+PKG_HASH:=5c4319f5214ada20807857dc8fdf3dc7d2afe8d6dd38f5c516c72e2be47d2227
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-flask-socketio
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=Socket.IO integration for Flask
+  URL:=https://github.com/miguelgrinberg/Flask-SocketIO/
+  DEPENDS:= \
+	+python3-light \
+	+python3-flask \
+	+python3-socketio
+endef
+
+define Package/python3-flask-socketio/description
+  Flask-SocketIO gives Flask applications access to low latency
+  bi-directional communications between the clients and the server.
+endef
+
+$(eval $(call Py3Package,python3-flask-socketio))
+$(eval $(call BuildPackage,python3-flask-socketio))
+$(eval $(call BuildPackage,python3-flask-socketio-src))