device-observatory: Fix compilation with uClibc-ng
Two protocol definitions are missing. Took values from Musl. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
4072e78dbe
commit
bae0448263
2 changed files with 23 additions and 1 deletions
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=device-observatory
|
||||
PKG_VERSION:=1.2.0
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/mwarning/device-observatory/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
|
|
22
utils/device-observatory/patches/010-uClibc-ng.patch
Normal file
22
utils/device-observatory/patches/010-uClibc-ng.patch
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- a/src/parse_ether.c
|
||||
+++ b/src/parse_ether.c
|
||||
@@ -21,10 +21,18 @@
|
||||
#include "parse_ether.h"
|
||||
|
||||
/* tcpdump header (ether.h) defines ETHER_HDRLEN) */
|
||||
-#ifndef ETHER_HDRLEN
|
||||
+#ifndef ETHER_HDRLEN
|
||||
#define ETHER_HDRLEN 14
|
||||
#endif
|
||||
|
||||
+/* uClibc-ng compatibility */
|
||||
+#ifndef IPPROTO_BEETPH
|
||||
+#define IPPROTO_BEETPH 94
|
||||
+#endif
|
||||
+
|
||||
+#ifndef IPPROTO_MPLS
|
||||
+#define IPPROTO_MPLS 137
|
||||
+#endif
|
||||
|
||||
const char *ip_protcol_str(int p)
|
||||
{
|
Loading…
Reference in a new issue