alsa-lib: update to 1.1.5
Signed-off-by: Peter Wagner <tripolar@gmx.at>
This commit is contained in:
parent
80e12d2525
commit
ba9fcb1fe0
2 changed files with 2 additions and 144 deletions
|
@ -8,14 +8,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=alsa-lib
|
||||
PKG_VERSION:=1.1.4.1
|
||||
PKG_VERSION:=1.1.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/lib/ \
|
||||
http://distfiles.gentoo.org/distfiles/
|
||||
|
||||
PKG_HASH:=91bb870c14d1c7c269213285eeed874fa3d28112077db061a3af8010d0885b76
|
||||
PKG_HASH:=f4f68ad3c6da36b0b5241ac3c798a7a71e0e97d51f972e9f723b3f20a9650ae6
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
|
||||
Peter Wagner <tripolar@gmx.at>
|
||||
|
||||
|
|
|
@ -1,142 +0,0 @@
|
|||
--- a/aserver/aserver.c
|
||||
+++ b/aserver/aserver.c
|
||||
@@ -20,7 +20,7 @@
|
||||
|
||||
#include <sys/shm.h>
|
||||
#include <sys/socket.h>
|
||||
-#include <sys/poll.h>
|
||||
+#include <poll.h>
|
||||
#include <sys/un.h>
|
||||
#include <sys/uio.h>
|
||||
#include <stdio.h>
|
||||
--- a/include/asoundlib-head.h
|
||||
+++ b/include/asoundlib-head.h
|
||||
@@ -35,6 +35,6 @@
|
||||
#include <string.h>
|
||||
#include <fcntl.h>
|
||||
#include <assert.h>
|
||||
-#include <sys/poll.h>
|
||||
+#include <poll.h>
|
||||
#include <errno.h>
|
||||
#include <stdarg.h>
|
||||
--- a/include/asoundlib.h
|
||||
+++ b/include/asoundlib.h
|
||||
@@ -35,7 +35,7 @@
|
||||
#include <string.h>
|
||||
#include <fcntl.h>
|
||||
#include <assert.h>
|
||||
-#include <sys/poll.h>
|
||||
+#include <poll.h>
|
||||
#include <errno.h>
|
||||
#include <stdarg.h>
|
||||
#include <endian.h>
|
||||
--- a/include/local.h
|
||||
+++ b/include/local.h
|
||||
@@ -47,7 +47,7 @@
|
||||
#error Header defining endianness not defined
|
||||
#endif
|
||||
#include <stdarg.h>
|
||||
-#include <sys/poll.h>
|
||||
+#include <poll.h>
|
||||
#include <sys/types.h>
|
||||
#include <errno.h>
|
||||
#if defined(__linux__)
|
||||
--- a/src/control/control.c
|
||||
+++ b/src/control/control.c
|
||||
@@ -90,7 +90,7 @@ against the original design.
|
||||
#include <string.h>
|
||||
#include <fcntl.h>
|
||||
#include <signal.h>
|
||||
-#include <sys/poll.h>
|
||||
+#include <poll.h>
|
||||
#include <stdbool.h>
|
||||
#include "control_local.h"
|
||||
|
||||
--- a/src/control/control_shm.c
|
||||
+++ b/src/control/control_shm.c
|
||||
@@ -27,7 +27,7 @@
|
||||
#include <fcntl.h>
|
||||
#include <sys/shm.h>
|
||||
#include <sys/socket.h>
|
||||
-#include <sys/poll.h>
|
||||
+#include <poll.h>
|
||||
#include <sys/un.h>
|
||||
#include <sys/uio.h>
|
||||
#include <sys/mman.h>
|
||||
--- a/src/pcm/pcm.c
|
||||
+++ b/src/pcm/pcm.c
|
||||
@@ -651,7 +651,7 @@ playback devices.
|
||||
#include <stdarg.h>
|
||||
#include <signal.h>
|
||||
#include <ctype.h>
|
||||
-#include <sys/poll.h>
|
||||
+#include <poll.h>
|
||||
#include <sys/mman.h>
|
||||
#include <limits.h>
|
||||
#include "pcm_local.h"
|
||||
--- a/src/pcm/pcm_direct.c
|
||||
+++ b/src/pcm/pcm_direct.c
|
||||
@@ -30,7 +30,7 @@
|
||||
#include <grp.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/mman.h>
|
||||
-#include <sys/poll.h>
|
||||
+#include <poll.h>
|
||||
#include <sys/shm.h>
|
||||
#include <sys/sem.h>
|
||||
#include <sys/wait.h>
|
||||
--- a/src/pcm/pcm_mmap.c
|
||||
+++ b/src/pcm/pcm_mmap.c
|
||||
@@ -22,7 +22,7 @@
|
||||
#include <stdio.h>
|
||||
#include <malloc.h>
|
||||
#include <string.h>
|
||||
-#include <sys/poll.h>
|
||||
+#include <poll.h>
|
||||
#include <sys/mman.h>
|
||||
#ifdef HAVE_SYS_SHM_H
|
||||
#include <sys/shm.h>
|
||||
--- a/src/pcm/pcm_share.c
|
||||
+++ b/src/pcm/pcm_share.c
|
||||
@@ -34,7 +34,7 @@
|
||||
#include <signal.h>
|
||||
#include <math.h>
|
||||
#include <sys/socket.h>
|
||||
-#include <sys/poll.h>
|
||||
+#include <poll.h>
|
||||
#include <pthread.h>
|
||||
#include "pcm_local.h"
|
||||
|
||||
--- a/src/pcm/pcm_shm.c
|
||||
+++ b/src/pcm/pcm_shm.c
|
||||
@@ -36,7 +36,7 @@
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/shm.h>
|
||||
#include <sys/socket.h>
|
||||
-#include <sys/poll.h>
|
||||
+#include <poll.h>
|
||||
#include <sys/un.h>
|
||||
#include <sys/mman.h>
|
||||
#include <netinet/in.h>
|
||||
--- a/src/seq/seq.c
|
||||
+++ b/src/seq/seq.c
|
||||
@@ -777,7 +777,7 @@ void event_filter(snd_seq_t *seq, snd_se
|
||||
|
||||
*/
|
||||
|
||||
-#include <sys/poll.h>
|
||||
+#include <poll.h>
|
||||
#include "seq_local.h"
|
||||
|
||||
/****************************************************************************
|
||||
--- a/src/shmarea.c
|
||||
+++ b/src/shmarea.c
|
||||
@@ -27,7 +27,7 @@
|
||||
#include <malloc.h>
|
||||
#include <string.h>
|
||||
#include <errno.h>
|
||||
-#include <sys/poll.h>
|
||||
+#include <poll.h>
|
||||
#include <sys/mman.h>
|
||||
#include <sys/shm.h>
|
||||
#include "list.h"
|
Loading…
Reference in a new issue