Merge pull request #9713 from jefferyto/python-twisted-19.7.0
python-twisted: Update to 19.7.0, refresh patches
This commit is contained in:
commit
ba9ea5a8a7
3 changed files with 6 additions and 6 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=python-twisted
|
PKG_NAME:=python-twisted
|
||||||
PKG_VERSION:=19.2.1
|
PKG_VERSION:=19.7.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=Twisted-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=Twisted-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/T/Twisted
|
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/T/Twisted
|
||||||
PKG_HASH:=fa2c04c2d68a9be7fc3975ba4947f653a57a656776f24be58ff0fe4b9aaf3e52
|
PKG_HASH:=d5db93026568f60cacdc0615fcd21d46f694a6bfad0ef3ff53cde2b4bb85a39d
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-twisted-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-twisted-$(PKG_VERSION)
|
||||||
PKG_BUILD_DEPENDS:=libtirpc
|
PKG_BUILD_DEPENDS:=libtirpc
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/src/twisted/python/_setup.py
|
--- a/src/twisted/python/_setup.py
|
||||||
+++ b/src/twisted/python/_setup.py
|
+++ b/src/twisted/python/_setup.py
|
||||||
@@ -147,7 +147,6 @@ _CONSOLE_SCRIPTS = [
|
@@ -149,7 +149,6 @@ _CONSOLE_SCRIPTS = [
|
||||||
"conch = twisted.conch.scripts.conch:run",
|
"conch = twisted.conch.scripts.conch:run",
|
||||||
"mailmail = twisted.mail.scripts.mailmail:run",
|
"mailmail = twisted.mail.scripts.mailmail:run",
|
||||||
"pyhtmlizer = twisted.scripts.htmlizer:run",
|
"pyhtmlizer = twisted.scripts.htmlizer:run",
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/src/twisted/python/_setup.py
|
--- a/src/twisted/python/_setup.py
|
||||||
+++ b/src/twisted/python/_setup.py
|
+++ b/src/twisted/python/_setup.py
|
||||||
@@ -173,11 +173,6 @@ class ConditionalExtension(Extension, ob
|
@@ -175,11 +175,6 @@ class ConditionalExtension(Extension, ob
|
||||||
# The C extensions used for Twisted.
|
# The C extensions used for Twisted.
|
||||||
_EXTENSIONS = [
|
_EXTENSIONS = [
|
||||||
ConditionalExtension(
|
ConditionalExtension(
|
||||||
|
@ -12,7 +12,7 @@
|
||||||
"twisted.internet.iocpreactor.iocpsupport",
|
"twisted.internet.iocpreactor.iocpsupport",
|
||||||
sources=[
|
sources=[
|
||||||
"src/twisted/internet/iocpreactor/iocpsupport/iocpsupport.c",
|
"src/twisted/internet/iocpreactor/iocpsupport/iocpsupport.c",
|
||||||
@@ -241,12 +236,11 @@ def getSetupArgs(extensions=_EXTENSIONS)
|
@@ -284,12 +279,11 @@ def getSetupArgs(extensions=_EXTENSIONS,
|
||||||
"incremental >= 16.10.1",
|
"incremental >= 16.10.1",
|
||||||
"Automat >= 0.3.0",
|
"Automat >= 0.3.0",
|
||||||
"hyperlink >= 17.1.1",
|
"hyperlink >= 17.1.1",
|
||||||
|
@ -26,7 +26,7 @@
|
||||||
use_incremental=True,
|
use_incremental=True,
|
||||||
setup_requires=["incremental >= 16.10.1"],
|
setup_requires=["incremental >= 16.10.1"],
|
||||||
install_requires=requirements,
|
install_requires=requirements,
|
||||||
@@ -256,7 +250,7 @@ def getSetupArgs(extensions=_EXTENSIONS)
|
@@ -299,7 +293,7 @@ def getSetupArgs(extensions=_EXTENSIONS,
|
||||||
cmdclass=command_classes,
|
cmdclass=command_classes,
|
||||||
include_package_data=True,
|
include_package_data=True,
|
||||||
exclude_package_data={
|
exclude_package_data={
|
||||||
|
|
Loading…
Reference in a new issue