quota: update to 4.06
This includes a backport of quota commit 02b222a3, which removes the use of reallocarray. The musl C library does not provide reallocarray. Signed-off-by: W. Michael Petullo <mike@flyn.org>
This commit is contained in:
parent
9133e79ccb
commit
ba4839f3c7
2 changed files with 16 additions and 3 deletions
|
@ -6,12 +6,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=quota
|
||||
PKG_VERSION:=4.05
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=4.06
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/linuxquota
|
||||
PKG_HASH:=ef3b5b5d1014ed1344b46c1826145e20cbef8db967b522403c9a060761cf7ab9
|
||||
PKG_HASH:=2f3e03039f378d4f0d97acdb49daf581dcaad64d2e1ddf129495fd579fbd268d
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
|
|
13
utils/quota/patches/020-remove-reallocarray.patch
Normal file
13
utils/quota/patches/020-remove-reallocarray.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/quota.c b/quota.c
|
||||
index a6ed61f..a60de12 100644
|
||||
--- a/quota.c
|
||||
+++ b/quota.c
|
||||
@@ -385,7 +385,7 @@ int main(int argc, char **argv)
|
||||
break;
|
||||
case 259:
|
||||
fscount++;
|
||||
- fsnames = reallocarray(fsnames, fscount, sizeof(char *));
|
||||
+ fsnames = realloc(fsnames, fscount * sizeof(char *));
|
||||
if (!fsnames)
|
||||
die(1, _("Not enough memory for filesystem names"));
|
||||
fsnames[fscount - 1] = optarg;
|
Loading…
Reference in a new issue