Merge pull request #8424 from MikePetullo/lighttpd
lighttpd: update to 1.4.53
This commit is contained in:
commit
b9ad311fa7
3 changed files with 3 additions and 46 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=lighttpd
|
||||
PKG_VERSION:=1.4.49
|
||||
PKG_RELEASE:=5
|
||||
PKG_VERSION:=1.4.53
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://download.lighttpd.net/lighttpd/releases-1.4.x
|
||||
PKG_HASH:=aedf49d7127d9e4c0ea56618e9e945a17674dc46a37ac7990120f87dd939ce09
|
||||
PKG_HASH:=3bdfce1cf3e9650a556a8c26fb15342c5717c63f530c54693db632b0371dcb78
|
||||
|
||||
PKG_LICENSE:=BSD-3c
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
diff --git a/src/rand.c b/src/rand.c
|
||||
index 10cd025..63fbb0d 100644
|
||||
--- a/src/rand.c
|
||||
+++ b/src/rand.c
|
||||
@@ -226,7 +226,9 @@ int li_rand_bytes (unsigned char *buf, int num)
|
||||
void li_rand_cleanup (void)
|
||||
{
|
||||
#ifdef USE_OPENSSL_CRYPTO
|
||||
+ #if OPENSSL_VERSION_NUMBER < 0x10100000L
|
||||
RAND_cleanup();
|
||||
+ #endif
|
||||
#endif
|
||||
safe_memclear(xsubi, sizeof(xsubi));
|
||||
}
|
|
@ -1,29 +0,0 @@
|
|||
From 72f2c7559a1cd75b6d86e72358b4b78cdeefa5f4 Mon Sep 17 00:00:00 2001
|
||||
From: yangfl <yangfl@users.noreply.github.com>
|
||||
Date: Fri, 1 Feb 2019 15:05:32 +0800
|
||||
Subject: [PATCH] Disable auto loading mod_authn_file
|
||||
|
||||
Which will cause openwrt/packages#7737
|
||||
---
|
||||
src/configfile.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/configfile.c b/src/configfile.c
|
||||
index 1b2651b9..29bb2aa4 100644
|
||||
--- a/src/configfile.c
|
||||
+++ b/src/configfile.c
|
||||
@@ -482,9 +482,9 @@ static int config_insert(server *srv) {
|
||||
* existing lighttpd 1.4.x configs */
|
||||
if (contains_mod_auth) {
|
||||
if (append_mod_authn_file) {
|
||||
- ds = data_string_init();
|
||||
+ /* ds = data_string_init();
|
||||
buffer_copy_string_len(ds->value, CONST_STR_LEN("mod_authn_file"));
|
||||
- array_insert_unique(srv->srvconf.modules, (data_unset *)ds);
|
||||
+ array_insert_unique(srv->srvconf.modules, (data_unset *)ds); */
|
||||
}
|
||||
if (append_mod_authn_ldap) {
|
||||
#if defined(HAVE_LDAP_H) && defined(HAVE_LBER_H) && defined(HAVE_LIBLDAP) && defined(HAVE_LIBLBER)
|
||||
--
|
||||
2.20.1
|
||||
|
Loading…
Reference in a new issue