lame: import from oldpackages, upgrade to 3.99.5, add myself as pkg maintainer
Signed-off-by: Ted Hess <thess@kitschensync.net>
This commit is contained in:
parent
ab11a89555
commit
b98e5d85d9
2 changed files with 118 additions and 0 deletions
85
sound/lame/Makefile
Normal file
85
sound/lame/Makefile
Normal file
|
@ -0,0 +1,85 @@
|
||||||
|
#
|
||||||
|
# Copyright (C) 2007-2014 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# blogic@openwrt.org
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=lame
|
||||||
|
PKG_VERSION:=3.99.5
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=@SF/lame
|
||||||
|
PKG_MD5SUM:=84835b313d4a8b68f5349816d33e07ce
|
||||||
|
PKG_FIXUP:=autoreconf
|
||||||
|
|
||||||
|
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||||
|
|
||||||
|
PKG_LICENSE:=LGPLv2
|
||||||
|
PKG_LICENSE_FILES:=COPYING LICENSE
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
PKG_INSTALL=1
|
||||||
|
|
||||||
|
define Package/lame/Default
|
||||||
|
SECTION:=sound
|
||||||
|
CATEGORY:=Sound
|
||||||
|
URL:=http://sourceforge.net/projects/lame
|
||||||
|
DEPENDS:=@BUILD_PATENTED
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/lame
|
||||||
|
$(call Package/lame/Default)
|
||||||
|
TITLE:=lame
|
||||||
|
MENU:=1
|
||||||
|
DEPENDS += +libncurses
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/lame/description
|
||||||
|
lame mp3 encoder
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/lame-lib
|
||||||
|
$(call Package/lame/Default)
|
||||||
|
TITLE:=lame-lib
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/lame-lib/description
|
||||||
|
lame mp3 encoder libs
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
$(call Build/Configure/Default, \
|
||||||
|
--disable-nasm \
|
||||||
|
)
|
||||||
|
endef
|
||||||
|
|
||||||
|
|
||||||
|
define Package/lame/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lame $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/lame-lib/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*so* $(1)/usr/lib/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/InstallDev
|
||||||
|
$(INSTALL_DIR) $(1)/usr/include/lame
|
||||||
|
$(INSTALL_DATA) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/include/lame/*.h \
|
||||||
|
$(1)/usr/include/lame/
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
|
$(CP) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/lib/*.{la,so*} \
|
||||||
|
$(1)/usr/lib/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,lame-lib))
|
||||||
|
$(eval $(call BuildPackage,lame))
|
33
sound/lame/patches/001-automake-compat.patch
Normal file
33
sound/lame/patches/001-automake-compat.patch
Normal file
|
@ -0,0 +1,33 @@
|
||||||
|
--- a/configure.in
|
||||||
|
+++ b/configure.in
|
||||||
|
@@ -393,7 +393,7 @@ CONFIG_MATH_LIB="${USE_LIBM}"
|
||||||
|
|
||||||
|
dnl configure use of features
|
||||||
|
|
||||||
|
-AM_PATH_GTK(1.2.0, HAVE_GTK="yes", HAVE_GTK="no")
|
||||||
|
+HAVE_GTK="no"
|
||||||
|
|
||||||
|
dnl ElectricFence malloc debugging
|
||||||
|
AC_MSG_CHECKING(use of ElectricFence malloc debugging)
|
||||||
|
--- a/frontend/Makefile.am
|
||||||
|
+++ b/frontend/Makefile.am
|
||||||
|
@@ -35,7 +35,7 @@ lame_SOURCES = lame_main.c $(common_sour
|
||||||
|
mp3rtp_SOURCES = mp3rtp.c rtp.c $(common_sources)
|
||||||
|
mp3x_SOURCES = mp3x.c gtkanal.c gpkplotting.c $(common_sources)
|
||||||
|
|
||||||
|
-CFLAGS = @CFLAGS@ @GTK_CFLAGS@ @FRONTEND_CFLAGS@ @SNDFILE_CFLAGS@
|
||||||
|
+CFLAGS = @CFLAGS@ @FRONTEND_CFLAGS@ @SNDFILE_CFLAGS@
|
||||||
|
LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@ @SNDFILE_LIBS@
|
||||||
|
|
||||||
|
INCLUDES = -I$(top_srcdir)/libmp3lame -I$(top_srcdir)/include -I$(top_builddir)
|
||||||
|
--- a/frontend/Makefile.in
|
||||||
|
+++ b/frontend/Makefile.in
|
||||||
|
@@ -99,7 +99,7 @@ AUTOMAKE = @AUTOMAKE@
|
||||||
|
AWK = @AWK@
|
||||||
|
CC = @CC@
|
||||||
|
CCDEPMODE = @CCDEPMODE@
|
||||||
|
-CFLAGS = @CFLAGS@ @GTK_CFLAGS@ @FRONTEND_CFLAGS@ @SNDFILE_CFLAGS@
|
||||||
|
+CFLAGS = @CFLAGS@ @FRONTEND_CFLAGS@ @SNDFILE_CFLAGS@
|
||||||
|
CONFIG_DEFS = @CONFIG_DEFS@
|
||||||
|
CONFIG_MATH_LIB = @CONFIG_MATH_LIB@
|
||||||
|
CPP = @CPP@
|
Loading…
Reference in a new issue