Merge pull request #12817 from neheb/neo

neon: update to 0.31.2
This commit is contained in:
Rosen Penev 2020-07-16 00:39:11 -07:00 committed by GitHub
commit b94181276e
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
2 changed files with 3 additions and 18 deletions

View file

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=neon
PKG_VERSION:=0.31.1
PKG_RELEASE:=2
PKG_VERSION:=0.31.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://notroj.github.io/neon
PKG_HASH:=c9dfcee723050df37ce18ba449d7707b78e7ab8230f3a4c59d9112e17dc2718d
PKG_HASH:=cf1ee3ac27a215814a9c80803fcee4f0ede8466ebead40267a9bd115e16a8678
PKG_MAINTAINER:=Federico Di Marco <fededim@gmail.com>
PKG_LICENSE:=LGPL-2.1-or-later

View file

@ -1,15 +0,0 @@
--- a/src/ne_openssl.c
+++ b/src/ne_openssl.c
@@ -230,10 +230,10 @@ void ne_ssl_cert_validity_time(const ne_ssl_certificate *cert,
time_t *from, time_t *until)
{
if (from) {
- *from = asn1time_to_timet(X509_get_notBefore(cert->subject));
+ *from = asn1time_to_timet(X509_get0_notBefore(cert->subject));
}
if (until) {
- *until = asn1time_to_timet(X509_get_notAfter(cert->subject));
+ *until = asn1time_to_timet(X509_get0_notAfter(cert->subject));
}
}