net/vnstat: Update to 1.17
Update vnStat to 1.17 which fixes database issue.
Remove unecessary patch
Based on:
commit 79b6e9dc61
by
Jo-Philipp Wich <jo@mein.io>
Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
This commit is contained in:
parent
499ec98653
commit
b8cf63a654
5 changed files with 13 additions and 64 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=vnstat
|
||||
PKG_VERSION:=1.12
|
||||
PKG_VERSION:=1.17
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://humdi.net/vnstat
|
||||
PKG_MD5SUM:=a154b2196771e06a8accd1c24374009c
|
||||
PKG_HASH:=18e4c53576ca9e1ef2f0e063a6d83b0c44e3b1cf008560d658745df5c9aa7971
|
||||
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
@ -86,7 +86,7 @@ define Package/vnstat/install
|
|||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/vnstatd $(1)/usr/sbin/
|
||||
$(INSTALL_DIR) $(1)/etc
|
||||
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/vnstat.conf $(1)/etc/
|
||||
$(INSTALL_CONF) $(PKG_BUILD_DIR)/cfg/vnstat.conf $(1)/etc/
|
||||
$(INSTALL_DIR) $(1)/etc/config
|
||||
$(INSTALL_CONF) ./files/vnstat.config $(1)/etc/config/vnstat
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -66,11 +66,11 @@ install:
|
||||
|
||||
# install everything else
|
||||
install -d -m 755 $(BIN) $(SBIN) $(MAN)/man1 $(MAN)/man5
|
||||
- install -s -m 755 src/vnstat $(BIN)
|
||||
- install -s -m 755 src/vnstatd $(SBIN)
|
||||
+ install -m 755 src/vnstat $(BIN)
|
||||
+ install -m 755 src/vnstatd $(SBIN)
|
||||
@if [ -f "src/vnstati" ]; \
|
||||
- then echo install -s -m 755 src/vnstati $(BIN); \
|
||||
- install -s -m 755 src/vnstati $(BIN); \
|
||||
+ then echo install -m 755 src/vnstati $(BIN); \
|
||||
+ install -m 755 src/vnstati $(BIN); \
|
||||
fi
|
||||
|
||||
# update man pages, gzip it if previous version was done so
|
||||
@@ -139,12 +139,12 @@ bsdinstall:
|
||||
|
||||
# install binaries
|
||||
install -d -m 755 $(DESTDIR)/var/db/vnstat
|
||||
- install -s -m 755 src/vnstat $(BIN_BSD)
|
||||
- install -s -m 755 src/vnstatd $(SBIN_BSD)
|
||||
+ install -m 755 src/vnstat $(BIN_BSD)
|
||||
+ install -m 755 src/vnstatd $(SBIN_BSD)
|
||||
|
||||
@if [ -f "src/vnstati" ]; \
|
||||
- then echo install -s -m 755 src/vnstati $(BIN_BSD); \
|
||||
- install -s -m 755 src/vnstati $(BIN_BSD); \
|
||||
+ then echo install -m 755 src/vnstati $(BIN_BSD); \
|
||||
+ install -m 755 src/vnstati $(BIN_BSD); \
|
||||
fi
|
||||
|
||||
# install default config if such doesn't exist
|
|
@ -1,15 +0,0 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -33,12 +33,6 @@ debug:
|
||||
install:
|
||||
@echo "Installing vnStat..."
|
||||
|
||||
-# check that system is really Linux
|
||||
- @if [ `uname` != "Linux" ]; \
|
||||
- then echo "This isn't a Linux system. Maybe 'make bsdinstall' is what you need?"; \
|
||||
- false; \
|
||||
- fi
|
||||
-
|
||||
# check that there's something to install
|
||||
@if [ ! -f "src/vnstat" ] || [ ! -f "src/vnstatd" ]; \
|
||||
then echo "Nothing to install, run make first."; \
|
|
@ -1,10 +0,0 @@
|
|||
--- a/src/common.h
|
||||
+++ b/src/common.h
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <pwd.h>
|
||||
#include <grp.h>
|
||||
#include <libgen.h>
|
||||
+#include <fcntl.h>
|
||||
|
||||
#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__APPLE__) || defined(__FreeBSD_kernel__)
|
||||
#include <sys/param.h>
|
|
@ -1,6 +1,15 @@
|
|||
From: Jo-Philipp Wich <jo@mein.io>
|
||||
Date: Thu, 26 Jan 2017 15:30:00 +0100
|
||||
Subject: [PATCH] config: adjust default values
|
||||
|
||||
Adjust the default interval settings to be better suited for slower embedded
|
||||
devices.
|
||||
|
||||
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
|
||||
|
||||
--- a/cfg/vnstat.conf
|
||||
+++ b/cfg/vnstat.conf
|
||||
@@ -78,13 +78,13 @@ DaemonUser ""
|
||||
@@ -87,13 +87,13 @@ DaemonUser ""
|
||||
DaemonGroup ""
|
||||
|
||||
# how often (in seconds) interface data is updated
|
Loading…
Reference in a new issue