flac: Update to 1.33
Some adjustments to the configure flags. Removed upstreamed patches. Added PKG_BUILD_PARALLEL for faster compilation. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
4687ec17db
commit
b82bdd3f0e
6 changed files with 132 additions and 65 deletions
|
@ -8,21 +8,21 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=flac
|
||||
PKG_VERSION:=1.3.2
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.3.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://downloads.xiph.org/releases/flac/
|
||||
PKG_HASH:=91cfc3ed61dc40f47f050a109b08610667d73477af6ef36dcad31c31a4a8d53f
|
||||
PKG_HASH:=213e82bd716c9de6db2f98bcadbc4c24c7e2efe8c75939a1a84e28539c4e1748
|
||||
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
PKG_LICENSE:=GFDL-1.2 GPL-2 LGPL-2.1 BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=README COPYING.FDL COPYING.GPL COPYING.LGPL COPYING.Xiph
|
||||
PKG_CPE_ID:=cpe:/a:flac_project:flac
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_REMOVE_FILES:=autogen.sh aclocal.m4
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
@ -37,15 +37,18 @@ endef
|
|||
CONFIGURE_ARGS += \
|
||||
--disable-cpplibs \
|
||||
--disable-sse \
|
||||
--disable-3dnow \
|
||||
--disable-altivec \
|
||||
--disable-doxgen-docs \
|
||||
--disable-local-xmms-plugin \
|
||||
--disable-xmms-plugin \
|
||||
--disable-ogg \
|
||||
--disable-oggtest \
|
||||
--disable-thorough-tests \
|
||||
--disable-examples \
|
||||
--disable-rpath \
|
||||
$(if $(CONFIG_DEBUG),--enable-debug) \
|
||||
--enable-static
|
||||
--enable-static \
|
||||
--without-pic
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
|
|
|
@ -4,11 +4,11 @@
|
|||
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
|
||||
-SUBDIRS = doc include m4 man src examples test build objs microbench
|
||||
-SUBDIRS = doc include m4 man src test build objs microbench
|
||||
+SUBDIRS = include m4 src build objs
|
||||
|
||||
EXTRA_DIST = \
|
||||
COPYING.FDL \
|
||||
if EXAMPLES
|
||||
SUBDIRS += examples
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -30,11 +30,6 @@ SUBDIRS = \
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -386,10 +386,11 @@ fi
|
||||
|
||||
if test "x$debug" = xtrue; then
|
||||
CPPFLAGS="-DDEBUG $CPPFLAGS"
|
||||
- CFLAGS="-g $CFLAGS"
|
||||
+ CFLAGS=$(echo "$CFLAGS" | sed 's/-g[0-9]*//')
|
||||
+ CFLAGS="-g3 $CFLAGS"
|
||||
else
|
||||
CPPFLAGS="-DNDEBUG $CPPFLAGS"
|
||||
- CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//')
|
||||
+ CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//;s/-g[0-9]*//')
|
||||
CFLAGS="-O3 -funroll-loops $CFLAGS"
|
||||
fi
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -33,6 +33,8 @@ ACLOCAL_AMFLAGS = -I m4
|
||||
|
||||
SUBDIRS = include m4 src build objs
|
||||
|
||||
+ACLOCAL_AMFLAGS = -I m4
|
||||
+
|
||||
EXTRA_DIST = \
|
||||
COPYING.FDL \
|
||||
COPYING.GPL \
|
118
libs/flac/patches/010-utime.patch
Normal file
118
libs/flac/patches/010-utime.patch
Normal file
|
@ -0,0 +1,118 @@
|
|||
Return-Path: <rosenp@gmail.com>
|
||||
Received: from localhost.localdomain (76-14-106-55.rk.wavecable.com. [76.14.106.55])
|
||||
by smtp.gmail.com with ESMTPSA id f19sm148509170pfk.180.2019.08.09.13.01.06
|
||||
for <flac-dev@xiph.org>
|
||||
(version=TLS1_3 cipher=AEAD-AES256-GCM-SHA384 bits=256/256);
|
||||
Fri, 09 Aug 2019 13:01:06 -0700 (PDT)
|
||||
From: Rosen Penev <rosenp@gmail.com>
|
||||
To: flac-dev@xiph.org
|
||||
Subject: [PATCH] Switch to utimensat for newer POSIX versions
|
||||
Date: Fri, 9 Aug 2019 13:01:05 -0700
|
||||
Message-Id: <20190809200105.1443-1-rosenp@gmail.com>
|
||||
X-Mailer: git-send-email 2.17.1
|
||||
|
||||
Some libcs like uClibc-ng can optionally disable deprecated functions.
|
||||
utime is one of them. When done so, both the header and the function go
|
||||
missing.
|
||||
|
||||
This fixes flac_utime to work in such a situation.
|
||||
---
|
||||
include/share/compat.h | 10 +++++++++-
|
||||
src/libFLAC/metadata_iterators.c | 9 +++++++--
|
||||
src/share/grabbag/file.c | 9 +++++++--
|
||||
3 files changed, 23 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/include/share/compat.h b/include/share/compat.h
|
||||
index f3041655..a063c083 100644
|
||||
--- a/include/share/compat.h
|
||||
+++ b/include/share/compat.h
|
||||
@@ -112,9 +112,13 @@
|
||||
#include <sys/utime.h> /* for utime() */
|
||||
#endif
|
||||
#else
|
||||
+#if _POSIX_C_SOURCE >= 200809L
|
||||
+#include <fcntl.h>
|
||||
+#else
|
||||
#include <sys/types.h> /* some flavors of BSD (like OS X) require this to get time_t */
|
||||
#include <utime.h> /* for utime() */
|
||||
#endif
|
||||
+#endif
|
||||
|
||||
#if defined _MSC_VER
|
||||
# if _MSC_VER >= 1800
|
||||
@@ -160,11 +164,15 @@
|
||||
|
||||
#define flac_fopen fopen
|
||||
#define flac_chmod chmod
|
||||
-#define flac_utime utime
|
||||
#define flac_unlink unlink
|
||||
#define flac_rename rename
|
||||
#define flac_stat stat
|
||||
|
||||
+#if _POSIX_C_SOURCE >= 200809L
|
||||
+#define flac_utime(a, b) utimensat (AT_FDCWD, a, *b, 0)
|
||||
+#else
|
||||
+#define flac_utime utime
|
||||
+#endif
|
||||
#endif
|
||||
|
||||
#ifdef _WIN32
|
||||
diff --git a/src/libFLAC/metadata_iterators.c b/src/libFLAC/metadata_iterators.c
|
||||
index 352a6c7a..d5255eb9 100644
|
||||
--- a/src/libFLAC/metadata_iterators.c
|
||||
+++ b/src/libFLAC/metadata_iterators.c
|
||||
@@ -3422,13 +3422,18 @@ FLAC__bool get_file_stats_(const char *filename, struct flac_stat_s *stats)
|
||||
|
||||
void set_file_stats_(const char *filename, struct flac_stat_s *stats)
|
||||
{
|
||||
- struct utimbuf srctime;
|
||||
-
|
||||
FLAC__ASSERT(0 != filename);
|
||||
FLAC__ASSERT(0 != stats);
|
||||
|
||||
+#if _POSIX_C_SOURCE >= 200809L
|
||||
+ struct timespec srctime[2] = {};
|
||||
+ srctime[0].tv_sec = stats->st_atime;
|
||||
+ srctime[1].tv_sec = stats->st_mtime;
|
||||
+#else
|
||||
+ struct utimbuf srctime;
|
||||
srctime.actime = stats->st_atime;
|
||||
srctime.modtime = stats->st_mtime;
|
||||
+#endif
|
||||
(void)flac_chmod(filename, stats->st_mode);
|
||||
(void)flac_utime(filename, &srctime);
|
||||
#if !defined _MSC_VER && !defined __BORLANDC__ && !defined __MINGW32__
|
||||
diff --git a/src/share/grabbag/file.c b/src/share/grabbag/file.c
|
||||
index 2c67bebf..edd835a6 100644
|
||||
--- a/src/share/grabbag/file.c
|
||||
+++ b/src/share/grabbag/file.c
|
||||
@@ -27,7 +27,6 @@
|
||||
#include <fcntl.h> /* for _O_BINARY */
|
||||
#else
|
||||
#include <sys/types.h> /* some flavors of BSD (like OS X) require this to get time_t */
|
||||
-#include <utime.h> /* for utime() */
|
||||
#endif
|
||||
#if defined __EMX__
|
||||
#include <io.h> /* for setmode(), O_BINARY */
|
||||
@@ -53,11 +52,17 @@
|
||||
void grabbag__file_copy_metadata(const char *srcpath, const char *destpath)
|
||||
{
|
||||
struct flac_stat_s srcstat;
|
||||
- struct utimbuf srctime;
|
||||
|
||||
if(0 == flac_stat(srcpath, &srcstat)) {
|
||||
+#if _POSIX_C_SOURCE >= 200809L
|
||||
+ struct timespec srctime[2] = {};
|
||||
+ srctime[0].tv_sec = srcstat.st_atime;
|
||||
+ srctime[1].tv_sec = srcstat.st_mtime;
|
||||
+#else
|
||||
+ struct utimbuf srctime;
|
||||
srctime.actime = srcstat.st_atime;
|
||||
srctime.modtime = srcstat.st_mtime;
|
||||
+#endif
|
||||
(void)flac_chmod(destpath, srcstat.st_mode);
|
||||
(void)flac_utime(destpath, &srctime);
|
||||
}
|
||||
--
|
||||
2.17.1
|
||||
|
|
@ -1,27 +0,0 @@
|
|||
From 4f47b63e9c971e6391590caf00a0f2a5ed612e67 Mon Sep 17 00:00:00 2001
|
||||
From: Erik de Castro Lopo <erikd@mega-nerd.com>
|
||||
Date: Sat, 8 Apr 2017 18:34:49 +1000
|
||||
Subject: [PATCH] stream_decoder.c: Fix a memory leak
|
||||
|
||||
Leak reported by Secunia Research.
|
||||
---
|
||||
src/libFLAC/stream_decoder.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/src/libFLAC/stream_decoder.c b/src/libFLAC/stream_decoder.c
|
||||
index 14d5fe7f..a5527511 100644
|
||||
--- a/src/libFLAC/stream_decoder.c
|
||||
+++ b/src/libFLAC/stream_decoder.c
|
||||
@@ -1759,6 +1759,9 @@ FLAC__bool read_metadata_vorbiscomment_(FLAC__StreamDecoder *decoder, FLAC__Stre
|
||||
}
|
||||
memset (obj->comments[i].entry, 0, obj->comments[i].length) ;
|
||||
if (!FLAC__bitreader_read_byte_block_aligned_no_crc(decoder->private_->input, obj->comments[i].entry, obj->comments[i].length)) {
|
||||
+ /* Current i-th entry is bad, so we delete it. */
|
||||
+ free (obj->comments[i].entry) ;
|
||||
+ obj->comments[i].entry = NULL ;
|
||||
obj->num_comments = i;
|
||||
goto skip;
|
||||
}
|
||||
--
|
||||
2.17.0
|
||||
|
Loading…
Reference in a new issue