unbound: fix build on non-linux systems
Override places that call uname to detect target features
Signed-off-by: Felix Fietkau <nbd@nbd.name>
(cherry picked from commit cc1d0aa3d2
)
This commit is contained in:
parent
8ca8872b3d
commit
b81785de99
2 changed files with 22 additions and 0 deletions
|
@ -158,6 +158,8 @@ define Package/libunbound/config
|
|||
endif
|
||||
endef
|
||||
|
||||
CONFIGURE_VARS += UNAME=Linux
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-dsa \
|
||||
--disable-gost \
|
||||
|
|
20
net/unbound/patches/010-configure_uname.patch
Normal file
20
net/unbound/patches/010-configure_uname.patch
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -765,7 +765,7 @@ if test x_$ub_test_python != x_no; then
|
||||
fi
|
||||
fi
|
||||
|
||||
-if test "`uname`" = "NetBSD"; then
|
||||
+if test "${UNAME:-`uname`}" = "NetBSD"; then
|
||||
NETBSD_LINTFLAGS='"-D__RENAME(x)=" -D_NETINET_IN_H_'
|
||||
AC_SUBST(NETBSD_LINTFLAGS)
|
||||
fi
|
||||
@@ -1210,7 +1210,7 @@ esac
|
||||
AC_ARG_ENABLE(tfo-client, AS_HELP_STRING([--enable-tfo-client],[Enable TCP Fast Open for client mode]))
|
||||
case "$enable_tfo_client" in
|
||||
yes)
|
||||
- case `uname` in
|
||||
+ case ${UNAME:-`uname`} in
|
||||
Linux) AC_CHECK_DECL([MSG_FASTOPEN], [AC_MSG_WARN([Check the platform specific TFO kernel parameters are correctly configured to support client mode TFO])],
|
||||
[AC_MSG_ERROR([TCP Fast Open is not available for client mode: please rerun without --enable-tfo-client])],
|
||||
[AC_INCLUDES_DEFAULT
|
Loading…
Reference in a new issue