Revert "curl: update to 7.85.0"
This reverts commit 312ab68be4
.
Signed-off-by: Stan Grishin <stangri@melmac.ca>
This commit is contained in:
parent
384f9690f2
commit
b814eec3b5
4 changed files with 17 additions and 6 deletions
|
@ -4,7 +4,7 @@ comment "SSL support"
|
|||
|
||||
choice
|
||||
prompt "Selected SSL library"
|
||||
default LIBCURL_WOLFSSL
|
||||
default LIBCURL_MBEDTLS
|
||||
|
||||
config LIBCURL_MBEDTLS
|
||||
bool "mbed TLS"
|
||||
|
|
|
@ -8,13 +8,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=curl
|
||||
PKG_VERSION:=7.85.0
|
||||
PKG_VERSION:=7.83.1
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://github.com/curl/curl/releases/download/curl-$(PKG_VERSION:.=_)/ \
|
||||
PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
|
||||
https://curl.askapache.com/download/ \
|
||||
https://curl.se/download/
|
||||
PKG_HASH:=88b54a6d4b9a48cb4d873c7056dcba997ddd5b7be5a2d537a4acb55c20b04be6
|
||||
PKG_HASH:=2cb9c2356e7263a1272fd1435ef7cdebf2cd21400ec287b068396deb705c22c4
|
||||
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
|
10
net/curl/patches/100-wolfssl.patch
Normal file
10
net/curl/patches/100-wolfssl.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- a/m4/curl-wolfssl.m4
|
||||
+++ b/m4/curl-wolfssl.m4
|
||||
@@ -93,6 +93,7 @@ if test "x$OPT_WOLFSSL" != xno; then
|
||||
They are set up properly later if it is detected. */
|
||||
#undef SIZEOF_LONG
|
||||
#undef SIZEOF_LONG_LONG
|
||||
+#include <wolfssl/options.h>
|
||||
#include <wolfssl/ssl.h>
|
||||
]],[[
|
||||
return wolfSSL_Init();
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -158,7 +158,7 @@ CLEANFILES = $(VC10_LIBVCXPROJ) $(VC10_S
|
||||
@@ -155,7 +155,7 @@ CLEANFILES = $(VC10_LIBVCXPROJ) $(VC10_S
|
||||
bin_SCRIPTS = curl-config
|
||||
|
||||
SUBDIRS = lib src
|
||||
|
@ -9,7 +9,7 @@
|
|||
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
pkgconfig_DATA = libcurl.pc
|
||||
@@ -272,8 +272,6 @@ cygwinbin:
|
||||
@@ -269,8 +269,6 @@ cygwinbin:
|
||||
# We extend the standard install with a custom hook:
|
||||
install-data-hook:
|
||||
(cd include && $(MAKE) install)
|
||||
|
|
Loading…
Reference in a new issue