diff --git a/sound/alsa-utils/Makefile b/sound/alsa-utils/Makefile
index af53e2a07..9a1d863a7 100644
--- a/sound/alsa-utils/Makefile
+++ b/sound/alsa-utils/Makefile
@@ -8,15 +8,21 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=alsa-utils
-PKG_VERSION:=1.1.7
+PKG_VERSION:=1.1.9
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/utils/ \
 		http://distfiles.gentoo.org/distfiles/
-PKG_HASH:=1db27fb54ab7fdeb54b00d68b8a174808ffea198cfbd67e3c959482194e1540a
-PKG_INSTALL:=1
+PKG_HASH:=5ddf2cbddb4bd1a4a2a6492a09c25898b08c3ad64893c3655be14194cf0a213a
+
 PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
+PKG_LICENSE:=GPL-2.0-or-later
+PKG_LICENSE_FILES:=COPYING
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,7 +31,7 @@ define Package/alsa-utils
   CATEGORY:=Sound
   DEPENDS:=+alsa-lib +libncursesw +libpthread
   TITLE:=ALSA (Advanced Linux Sound Architecture) utilities
-  URL:=http://www.alsa-project.org/
+  URL:=https://www.alsa-project.org/
 endef
 
 define Package/alsa-utils-seq
@@ -33,7 +39,7 @@ define Package/alsa-utils-seq
   CATEGORY:=Sound
   DEPENDS:=+alsa-lib +libpthread
   TITLE:=ALSA sequencer utilities
-  URL:=http://www.alsa-project.org/
+  URL:=https://www.alsa-project.org/
 endef
 
 define Package/alsa-utils-tests
@@ -41,16 +47,16 @@ define Package/alsa-utils-tests
   CATEGORY:=Sound
   TITLE:=ALSA utilities test data (adds ~1.3M to image)
   DEPENDS:=+alsa-lib +libpthread
-  URL:=http://www.alsa-project.org/
+  URL:=https://www.alsa-project.org/
 endef
 
 CONFIGURE_ARGS+= \
-		--disable-rpath \
-		--disable-alsatest \
-		--disable-bat \
-		--disable-xmlto \
-		--disable-rst2man \
-		--with-curses=ncursesw
+	--disable-rpath \
+	--disable-alsatest \
+	--disable-bat \
+	--disable-xmlto \
+	--disable-rst2man \
+	--with-curses=ncursesw
 
 define Package/alsa-utils/install
 	$(INSTALL_DIR) $(1)/usr/{s,}bin
diff --git a/sound/alsa-utils/patches/100-uClibc-compat.patch b/sound/alsa-utils/patches/100-uClibc-compat.patch
index 987c9b8b7..21c87f0b7 100644
--- a/sound/alsa-utils/patches/100-uClibc-compat.patch
+++ b/sound/alsa-utils/patches/100-uClibc-compat.patch
@@ -1,6 +1,6 @@
 --- a/alsamixer/volume_mapping.c
 +++ b/alsamixer/volume_mapping.c
-@@ -114,9 +114,9 @@ static double get_normalized_volume(snd_
+@@ -108,9 +108,9 @@ static double get_normalized_volume(snd_
  	if (use_linear_dB_scale(min, max))
  		return (value - min) / (double)(max - min);
  
@@ -12,7 +12,7 @@
  		normalized = (normalized - min_norm) / (1 - min_norm);
  	}
  
-@@ -149,7 +149,7 @@ static int set_normalized_volume(snd_mix
+@@ -143,7 +143,7 @@ static int set_normalized_volume(snd_mix
  	}
  
  	if (min != SND_CTL_TLV_DB_GAIN_MUTE) {
diff --git a/sound/alsa-utils/patches/101-disable-libsamplerate.patch b/sound/alsa-utils/patches/101-disable-libsamplerate.patch
index 2b670d96e..f3dfa9d0c 100644
--- a/sound/alsa-utils/patches/101-disable-libsamplerate.patch
+++ b/sound/alsa-utils/patches/101-disable-libsamplerate.patch
@@ -1,5 +1,3 @@
-diff --git a/alsaloop/Makefile.am b/alsaloop/Makefile.am
-index 4cdf20b..0715b02 100644
 --- a/alsaloop/Makefile.am
 +++ b/alsaloop/Makefile.am
 @@ -1,9 +1,9 @@
@@ -15,21 +13,6 @@ index 4cdf20b..0715b02 100644
  # LDFLAGS = -static
  # CFLAGS += -g -Wall
  
-diff --git a/alsaloop/Makefile.in b/alsaloop/Makefile.in
-index 374cbcc..25dbae3 100644
---- a/alsaloop/Makefile.in
-+++ b/alsaloop/Makefile.in
-@@ -51,7 +51,7 @@ PRE_UNINSTALL = :
- POST_UNINSTALL = :
- build_triplet = @build@
- host_triplet = @host@
--@HAVE_SAMPLERATE_TRUE@am__append_1 = -lsamplerate
-+# @HAVE_SAMPLERATE_TRUE@am__append_1 = -lsamplerate
- bin_PROGRAMS = alsaloop$(EXEEXT)
- subdir = alsaloop
- DIST_COMMON = $(noinst_HEADERS) $(srcdir)/Makefile.am \
-diff --git a/configure.ac b/configure.ac
-index 3e8f1e8..487e5de 100644
 --- a/configure.ac
 +++ b/configure.ac
 @@ -38,8 +38,8 @@ AC_CHECK_HEADERS([alsa/use-case.h], [have_ucm="yes"], [have_ucm="no"],