zstd: update to 1.4.8
Remove upstreamed patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
55593507ab
commit
b599c11aa8
2 changed files with 3 additions and 24 deletions
|
@ -1,12 +1,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=zstd
|
||||
PKG_VERSION:=1.4.5
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.4.8
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.zst
|
||||
PKG_SOURCE_URL:=https://github.com/facebook/zstd/releases/download/v$(PKG_VERSION)
|
||||
PKG_HASH:=2c2366874bc449ff539614266d8c0d6ecdb4baf30bb65609c239ab4ed23c03c7
|
||||
PKG_HASH:=c7ea10e20dd61b457220455e3cf553069987b968b7c63d1b9d46acbdb45623eb
|
||||
|
||||
PKG_MAINTAINER:=
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
--- a/build/meson/meson.build
|
||||
+++ b/build/meson/meson.build
|
||||
@@ -22,7 +22,6 @@ project('zstd',
|
||||
cc = meson.get_compiler('c')
|
||||
cxx = meson.get_compiler('cpp')
|
||||
pkgconfig = import('pkgconfig')
|
||||
-python3 = import('python').find_installation()
|
||||
windows_mod = import('windows')
|
||||
|
||||
host_machine_os = host_machine.system()
|
||||
@@ -40,8 +39,8 @@ compiler_msvc = 'msvc'
|
||||
zstd_version = meson.project_version()
|
||||
|
||||
zstd_h_file = join_paths(meson.current_source_dir(), '../../lib/zstd.h')
|
||||
-GetZstdLibraryVersion_py = files('GetZstdLibraryVersion.py')
|
||||
-r = run_command(python3, GetZstdLibraryVersion_py, zstd_h_file)
|
||||
+GetZstdLibraryVersion_py = find_program('GetZstdLibraryVersion.py', native : true)
|
||||
+r = run_command(GetZstdLibraryVersion_py, zstd_h_file)
|
||||
if r.returncode() == 0
|
||||
zstd_version = r.stdout().strip()
|
||||
message('Project version is now: @0@'.format(zstd_version))
|
Loading…
Reference in a new issue