setools: new package
Signed-off-by: W. Michael Petullo <mike@flyn.org>
This commit is contained in:
parent
e697684d6f
commit
b4f70592a7
2 changed files with 52 additions and 0 deletions
41
utils/setools/Makefile
Normal file
41
utils/setools/Makefile
Normal file
|
@ -0,0 +1,41 @@
|
|||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=setools
|
||||
PKG_VERSION:=4.3.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://github.com/SELinuxProject/setools/releases/download/4.3.0
|
||||
PKG_HASH:=315df3ae0eb29b399123c5e3330480c5d1c0da038671c9fd62a439c49a6f9105
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/setools
|
||||
|
||||
HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=Cython # Cython>=0.27
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||
PKG_LICENSE:=GPL-2.0-or-later LGPL-2.1-or-later
|
||||
PKG_LICENSE_FILES:=COPYING COPYING.GPL COPYING.LGPL
|
||||
PKG_CPE_ID:=cpe:/a:selinuxproject:setools
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../../lang/python/python3-package.mk
|
||||
|
||||
define Package/setools
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=+python3 +python3-pkg-resources +python3-networkx +libselinux +libsepol
|
||||
TITLE:=Policy analysis tools for SELinux
|
||||
URL:=http://selinuxproject.org/page/Main_Page
|
||||
endef
|
||||
|
||||
define Package/setools/description
|
||||
SETools is a collection of tools and libraries designed to facilitate
|
||||
SELinux policy analysis.
|
||||
endef
|
||||
|
||||
$(eval $(call Py3Package,setools))
|
||||
$(eval $(call BuildPackage,setools))
|
11
utils/setools/patches/010-fewer-warnings.patch
Normal file
11
utils/setools/patches/010-fewer-warnings.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
diff -u --recursive setools-vanilla/setup.py setools/setup.py
|
||||
--- setools-vanilla/setup.py 2020-04-01 09:57:49.000000000 -0500
|
||||
+++ setools/setup.py 2020-08-12 21:44:41.265149504 -0500
|
||||
@@ -109,7 +109,6 @@
|
||||
extra_compile_args=['-Werror', '-Wextra',
|
||||
'-Waggregate-return',
|
||||
'-Wfloat-equal',
|
||||
- '-Wformat', '-Wformat=2',
|
||||
'-Winit-self',
|
||||
'-Wmissing-format-attribute',
|
||||
'-Wmissing-include-dirs',
|
Loading…
Reference in a new issue