Merge pull request #12604 from neheb/v4l22
v4l2rtpspserver: update to 0.2.0
This commit is contained in:
commit
b4be5e1934
2 changed files with 48 additions and 5 deletions
|
@ -7,17 +7,17 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=v4l2rtspserver
|
PKG_NAME:=v4l2rtspserver
|
||||||
PKG_VERSION:=0.1.9
|
PKG_VERSION:=0.2.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
#cannot use codeload as this uses submodules
|
#cannot use codeload as this uses submodules
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_URL:=https://github.com/mpromonet/v4l2rtspserver
|
PKG_SOURCE_URL:=https://github.com/mpromonet/v4l2rtspserver
|
||||||
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
|
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
|
||||||
PKG_MIRROR_HASH:=bcb68170f6b6a3560902673c4145d0311d4f661b2ed3d71ed1ee1a58bdde96d2
|
PKG_MIRROR_HASH:=ddc4217ee12e57a4c248b6667309559323458028dc0fa085942b91dbbcd74146
|
||||||
|
|
||||||
LIVE555_VERSION:=2019.11.22
|
LIVE555_VERSION:=2020.11.29
|
||||||
LIVE555_HASH:=cd10fbd2d28d0bc39c12ec57b9f6b13fab3bfc7005f5ac8f9c94a9eb34179e90
|
LIVE555_HASH:=0300f1f0b92529909623d3e870edeadff9841bbc9097a481a8583c5b9a6cc3ae
|
||||||
LIVE555_FILE:=live.$(LIVE555_VERSION).tar.gz
|
LIVE555_FILE:=live.$(LIVE555_VERSION).tar.gz
|
||||||
|
|
||||||
PKG_MAINTAINER:=Roger Dammit <rogerdammit@gmail.com>
|
PKG_MAINTAINER:=Roger Dammit <rogerdammit@gmail.com>
|
||||||
|
@ -56,7 +56,9 @@ endef
|
||||||
TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
|
TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
|
||||||
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
|
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
|
||||||
|
|
||||||
CMAKE_OPTIONS += -DALSA=OFF -DLIVE555CFLAGS="$(TARGET_CFLAGS) -DSOCKLEN_T=socklen_t -D_LARGEFILE_SOURCE=1 -D_FILE_OFFSET_BITS=64 -DLOCALE_NOT_USED -DNO_SSTREAM=1 -DALLOW_RTSP_SERVER_PORT_REUSE=1 -DVERSION=\\\"$(PKG_VERSION)\\\""
|
CMAKE_OPTIONS += \
|
||||||
|
-DALSA=OFF \
|
||||||
|
-DLIVE555CFLAGS=" -DSOCKLEN_T=socklen_t -D_LARGEFILE_SOURCE=1 -D_FILE_OFFSET_BITS=64 -DLOCALE_NOT_USED -DNO_SSTREAM=1 -DALLOW_RTSP_SERVER_PORT_REUSE=1 -DNO_OPENSSL"
|
||||||
|
|
||||||
define Build/Prepare
|
define Build/Prepare
|
||||||
$(Build/Prepare/Default)
|
$(Build/Prepare/Default)
|
||||||
|
|
41
multimedia/v4l2rtspserver/patches/010-live555.patch
Normal file
41
multimedia/v4l2rtspserver/patches/010-live555.patch
Normal file
|
@ -0,0 +1,41 @@
|
||||||
|
From f0f04b7315f59b3a9b814c13c705d4354d0c0626 Mon Sep 17 00:00:00 2001
|
||||||
|
From: mpromonet <michel.promonet@free.fr>
|
||||||
|
Date: Fri, 27 Nov 2020 19:36:43 +0100
|
||||||
|
Subject: [PATCH] fix #216: allow to build with live555 newer than 2020.11.27
|
||||||
|
(2020.11.25 & 2020.11.26 doesnot build)
|
||||||
|
|
||||||
|
---
|
||||||
|
inc/HTTPServer.h | 9 +++++++--
|
||||||
|
1 file changed, 7 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
--- a/inc/HTTPServer.h
|
||||||
|
+++ b/inc/HTTPServer.h
|
||||||
|
@@ -113,13 +113,18 @@ class TCPSink: public MediaSink {
|
||||||
|
// ---------------------------------------------------------
|
||||||
|
// Extend RTSP server to add support for HLS and MPEG-DASH
|
||||||
|
// ---------------------------------------------------------
|
||||||
|
+#if LIVEMEDIA_LIBRARY_VERSION_INT < 1606435200
|
||||||
|
+#define SOCKETCLIENT sockaddr_in
|
||||||
|
+#else
|
||||||
|
+#define SOCKETCLIENT sockaddr_storage
|
||||||
|
+#endif
|
||||||
|
class HTTPServer : public RTSPServer
|
||||||
|
{
|
||||||
|
|
||||||
|
class HTTPClientConnection : public RTSPServer::RTSPClientConnection
|
||||||
|
{
|
||||||
|
public:
|
||||||
|
- HTTPClientConnection(RTSPServer& ourServer, int clientSocket, struct sockaddr_in clientAddr)
|
||||||
|
+ HTTPClientConnection(RTSPServer& ourServer, int clientSocket, struct SOCKETCLIENT clientAddr)
|
||||||
|
: RTSPServer::RTSPClientConnection(ourServer, clientSocket, clientAddr), m_TCPSink(NULL), m_StreamToken(NULL), m_Subsession(NULL), m_Source(NULL) {
|
||||||
|
}
|
||||||
|
virtual ~HTTPClientConnection();
|
||||||
|
@@ -165,7 +170,7 @@ class HTTPServer : public RTSPServer
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
- RTSPServer::RTSPClientConnection* createNewClientConnection(int clientSocket, struct sockaddr_in clientAddr)
|
||||||
|
+ RTSPServer::RTSPClientConnection* createNewClientConnection(int clientSocket, struct SOCKETCLIENT clientAddr)
|
||||||
|
{
|
||||||
|
return new HTTPClientConnection(*this, clientSocket, clientAddr);
|
||||||
|
}
|
Loading…
Reference in a new issue