samba4: Update to 4.9.2
Update Samba to 4.9.2 Refresh patches Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
This commit is contained in:
parent
a20433e813
commit
b4b451055d
7 changed files with 44 additions and 53 deletions
|
@ -2,8 +2,8 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=samba
|
||||
PKG_VERSION:=4.9.1
|
||||
PKG_RELEASE:=4
|
||||
PKG_VERSION:=4.9.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_MAINTAINER:=Andy Walsh <andy.walsh44+github@gmail.com>
|
||||
PKG_LICENSE:=GPL-3.0-only
|
||||
|
@ -11,7 +11,7 @@ PKG_LICENSE_FILES:=COPYING
|
|||
|
||||
PKG_SOURCE_URL:=https://download.samba.org/pub/samba/stable/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_HASH:=33118cbe83a87be085eba1aae6e597878b02d6ac9b2da67454ed33cf3e9853f2
|
||||
PKG_HASH:=349c17b7bf1bf667167843470533da89ff1b2ca4a768b529aaacf5197af1efa2
|
||||
|
||||
# Buildroot bug? Can't add target deps via '+SAMBA4_SERVER_AD_DC:python-crypto' (as work-around we select via config.in)
|
||||
PKG_BUILD_DEPENDS:=SAMBA4_SERVER_AD_DC:python-crypto nfs-kernel-server/host
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- samba-4.4.0rc2/source3/wscript
|
||||
+++ samba-4.4.0rc2/source3/wscript
|
||||
@@ -870,7 +870,7 @@
|
||||
--- a/source3/wscript
|
||||
+++ b/source3/wscript
|
||||
@@ -843,7 +843,7 @@ msg.msg_accrightslen = sizeof(fd);
|
||||
if conf.env.with_iconv:
|
||||
conf.DEFINE('HAVE_ICONV', 1)
|
||||
|
||||
|
@ -9,9 +9,9 @@
|
|||
use_pam=True
|
||||
conf.CHECK_HEADERS('security/pam_appl.h pam/pam_appl.h')
|
||||
if not conf.CONFIG_SET('HAVE_SECURITY_PAM_APPL_H') and not conf.CONFIG_SET('HAVE_PAM_PAM_APPL_H'):
|
||||
@@ -943,6 +943,17 @@
|
||||
conf.DEFINE('WITH_PAM', 1)
|
||||
conf.DEFINE('WITH_PAM_MODULES', 1)
|
||||
@@ -920,6 +920,17 @@ int i; i = PAM_RADIO_TYPE;
|
||||
"or headers not found. Use --without-pam to disable "
|
||||
"PAM support.");
|
||||
|
||||
+ else:
|
||||
+ Logs.warn("PAM disabled")
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
--- a/source3/lib/messages.c
|
||||
+++ b/source3/lib/messages.c
|
||||
@@ -221,7 +221,7 @@ struct messaging_context *messaging_init
|
||||
return NULL;
|
||||
@@ -518,7 +518,7 @@ static NTSTATUS messaging_init_internal(
|
||||
return NT_STATUS_ACCESS_DENIED;
|
||||
}
|
||||
|
||||
- priv_path = private_path("msg.sock");
|
||||
+ priv_path = lock_path("msg.sock");
|
||||
if (priv_path == NULL) {
|
||||
TALLOC_FREE(ctx);
|
||||
return NULL;
|
||||
@@ -311,7 +311,7 @@ NTSTATUS messaging_reinit(struct messagi
|
||||
return NT_STATUS_NO_MEMORY;
|
||||
}
|
||||
@@ -662,7 +662,7 @@ NTSTATUS messaging_reinit(struct messagi
|
||||
|
||||
msg_ctx->msg_dgm_ref = messaging_dgm_ref(
|
||||
msg_ctx, msg_ctx->event_ctx, &msg_ctx->id.unique_id,
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/source4/lib/messaging/messaging.c
|
||||
+++ b/source4/lib/messaging/messaging.c
|
||||
@@ -323,7 +323,7 @@ struct imessaging_context *imessaging_in
|
||||
@@ -350,7 +350,7 @@ static struct imessaging_context *imessa
|
||||
goto fail;
|
||||
}
|
||||
|
||||
|
|
|
@ -3,10 +3,8 @@ we just check whether does the module exist.
|
|||
|
||||
Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com>
|
||||
|
||||
Index: samba-4.4.2/buildtools/wafsamba/samba_bundled.py
|
||||
===================================================================
|
||||
--- samba-4.4.2.orig/buildtools/wafsamba/samba_bundled.py
|
||||
+++ samba-4.4.2/buildtools/wafsamba/samba_bundled.py
|
||||
--- a/buildtools/wafsamba/samba_bundled.py
|
||||
+++ b/buildtools/wafsamba/samba_bundled.py
|
||||
@@ -2,6 +2,7 @@
|
||||
|
||||
import sys
|
||||
|
@ -15,7 +13,7 @@ Index: samba-4.4.2/buildtools/wafsamba/samba_bundled.py
|
|||
from Configure import conf
|
||||
from samba_utils import TO_LIST
|
||||
|
||||
@@ -230,17 +231,32 @@ def CHECK_BUNDLED_SYSTEM_PYTHON(conf, li
|
||||
@@ -249,17 +250,32 @@ def CHECK_BUNDLED_SYSTEM_PYTHON(conf, li
|
||||
# versions
|
||||
minversion = minimum_library_version(conf, libname, minversion)
|
||||
|
||||
|
|
|
@ -2,12 +2,10 @@ Don't check xsltproc manpages
|
|||
|
||||
Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com>
|
||||
|
||||
Index: samba-4.4.2/lib/ldb/wscript
|
||||
===================================================================
|
||||
--- samba-4.4.2.orig/lib/ldb/wscript
|
||||
+++ samba-4.4.2/lib/ldb/wscript
|
||||
@@ -65,7 +65,7 @@ def configure(conf):
|
||||
conf.define('USING_SYSTEM_LDB', 1)
|
||||
--- a/lib/ldb/wscript
|
||||
+++ b/lib/ldb/wscript
|
||||
@@ -152,7 +152,7 @@ def configure(conf):
|
||||
conf.DEFINE('EXPECTED_SYSTEM_LDB_VERSION_RELEASE', int(v[2]))
|
||||
|
||||
if conf.env.standalone_ldb:
|
||||
- conf.CHECK_XSLTPROC_MANPAGES()
|
||||
|
@ -15,24 +13,20 @@ Index: samba-4.4.2/lib/ldb/wscript
|
|||
|
||||
# we need this for the ldap backend
|
||||
if conf.CHECK_FUNCS_IN('ber_flush ldap_open ldap_initialize', 'lber ldap', headers='lber.h ldap.h'):
|
||||
Index: samba-4.4.2/lib/talloc/wscript
|
||||
===================================================================
|
||||
--- samba-4.4.2.orig/lib/talloc/wscript
|
||||
+++ samba-4.4.2/lib/talloc/wscript
|
||||
@@ -56,7 +56,7 @@ def configure(conf):
|
||||
if conf.env.standalone_talloc:
|
||||
conf.env.TALLOC_COMPAT1 = Options.options.TALLOC_COMPAT1
|
||||
--- a/lib/talloc/wscript
|
||||
+++ b/lib/talloc/wscript
|
||||
@@ -49,7 +49,7 @@ def configure(conf):
|
||||
conf.env.PKGCONFIGDIR = '${LIBDIR}/pkgconfig'
|
||||
conf.env.TALLOC_VERSION = VERSION
|
||||
|
||||
- conf.CHECK_XSLTPROC_MANPAGES()
|
||||
+ #conf.CHECK_XSLTPROC_MANPAGES()
|
||||
|
||||
if not conf.env.disable_python:
|
||||
# also disable if we don't have the python libs installed
|
||||
Index: samba-4.4.2/lib/tdb/wscript
|
||||
===================================================================
|
||||
--- samba-4.4.2.orig/lib/tdb/wscript
|
||||
+++ samba-4.4.2/lib/tdb/wscript
|
||||
@@ -92,7 +92,7 @@ def configure(conf):
|
||||
conf.CHECK_HEADERS('sys/auxv.h')
|
||||
conf.CHECK_FUNCS('getauxval')
|
||||
--- a/lib/tdb/wscript
|
||||
+++ b/lib/tdb/wscript
|
||||
@@ -89,7 +89,7 @@ def configure(conf):
|
||||
not conf.env.disable_tdb_mutex_locking):
|
||||
conf.define('USE_TDB_MUTEX_LOCKING', 1)
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- a/lib/crypto/wscript_configure 2018-07-26
|
||||
+++ b/lib/crypto/wscript_configure 2018-08-27
|
||||
--- a/lib/crypto/wscript_configure
|
||||
+++ b/lib/crypto/wscript_configure
|
||||
@@ -2,11 +2,11 @@
|
||||
import Options
|
||||
import Utils
|
||||
|
@ -19,12 +19,17 @@
|
|||
checklibc=True)
|
||||
--- a/lib/replace/wscript
|
||||
+++ b/lib/replace/wscript
|
||||
@@ -302,22 +302,13 @@ def configure(conf):
|
||||
@@ -340,22 +340,13 @@ def configure(conf):
|
||||
|
||||
conf.CHECK_FUNCS('prctl dirname basename')
|
||||
|
||||
- strlcpy_in_bsd = False
|
||||
-
|
||||
+ # Not checking for libbsd
|
||||
+ conf.CHECK_FUNCS('strlcpy strlcat')
|
||||
+ conf.CHECK_FUNCS('getpeereid')
|
||||
+ conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h')
|
||||
+ conf.CHECK_FUNCS('setproctitle_init')
|
||||
|
||||
- # libbsd on some platforms provides strlcpy and strlcat
|
||||
- if not conf.CHECK_FUNCS('strlcpy strlcat'):
|
||||
- if conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h',
|
||||
|
@ -39,17 +44,11 @@
|
|||
-
|
||||
- if not conf.CHECK_FUNCS('closefrom'):
|
||||
- conf.CHECK_FUNCS_IN('closefrom', 'bsd', headers='bsd/unistd.h')
|
||||
+ # Not checking for libbsd
|
||||
+ conf.CHECK_FUNCS('strlcpy strlcat')
|
||||
+ conf.CHECK_FUNCS('getpeereid')
|
||||
+ conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h')
|
||||
+ conf.CHECK_FUNCS('setproctitle_init')
|
||||
+
|
||||
+ conf.CHECK_FUNCS('closefrom')
|
||||
|
||||
conf.CHECK_CODE('''
|
||||
struct ucred cred;
|
||||
@@ -667,9 +658,6 @@ removeea setea
|
||||
@@ -698,9 +689,6 @@ def configure(conf):
|
||||
|
||||
# look for a method of finding the list of network interfaces
|
||||
for method in ['HAVE_IFACE_GETIFADDRS', 'HAVE_IFACE_AIX', 'HAVE_IFACE_IFCONF', 'HAVE_IFACE_IFREQ']:
|
||||
|
@ -59,7 +58,7 @@
|
|||
if conf.CHECK_CODE('''
|
||||
#define %s 1
|
||||
#define NO_CONFIG_H 1
|
||||
@@ -682,7 +670,7 @@ removeea setea
|
||||
@@ -713,7 +701,7 @@ def configure(conf):
|
||||
#include "test/getifaddrs.c"
|
||||
''' % method,
|
||||
method,
|
||||
|
@ -68,7 +67,7 @@
|
|||
addmain=False,
|
||||
execute=True):
|
||||
break
|
||||
@@ -730,7 +718,6 @@ def build(bld):
|
||||
@@ -761,7 +749,6 @@ def build(bld):
|
||||
break
|
||||
|
||||
extra_libs = ''
|
||||
|
|
Loading…
Reference in a new issue