gnutls: updated to 3.4.2
Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
This commit is contained in:
parent
780cf06d28
commit
b3d2d64928
2 changed files with 3 additions and 29 deletions
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gnutls
|
||||
PKG_VERSION:=3.4.1
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=3.4.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_USE_MIPS16:=0
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=ftp://ftp.gnutls.org/gcrypt/gnutls/v3.4
|
||||
PKG_MD5SUM:=2d04f34fa25b45f9dcb9104c0394e12e
|
||||
PKG_MD5SUM:=4fb4a6253e09aa070e6c467cbb51ba33
|
||||
#PKG_FIXUP:=autoreconf gettext-version
|
||||
PKG_MAINTAINER:=Nikos Mavrogiannopoulos <nmav@gnutls.org>
|
||||
PKG_LICENSE:=LGPLv2.1+
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
From 6adde30fcea02d3cb541b5a5bfb3b12074f1f3e9 Mon Sep 17 00:00:00 2001
|
||||
From: Nikos Mavrogiannopoulos <nmav@redhat.com>
|
||||
Date: Thu, 14 May 2015 14:00:11 +0200
|
||||
Subject: [PATCH] camellia256-gcm: corrected regression
|
||||
|
||||
Reported by Manuel Pegourie-Gonnard.
|
||||
---
|
||||
lib/nettle/cipher.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/nettle/cipher.c b/lib/nettle/cipher.c
|
||||
index 59e70dd..74e4203 100644
|
||||
--- a/lib/nettle/cipher.c
|
||||
+++ b/lib/nettle/cipher.c
|
||||
@@ -302,7 +302,7 @@ static const struct nettle_cipher_st builtin_ciphers[] = {
|
||||
.ctx_size = sizeof(struct gcm_camellia256_ctx),
|
||||
.encrypt = _gcm_encrypt,
|
||||
.decrypt = _gcm_decrypt,
|
||||
- .set_encrypt_key = (nettle_set_key_func*)gcm_camellia128_set_key,
|
||||
+ .set_encrypt_key = (nettle_set_key_func*)gcm_camellia256_set_key,
|
||||
.set_decrypt_key = (nettle_set_key_func*)gcm_camellia256_set_key,
|
||||
|
||||
.tag = (nettle_hash_digest_func*)gcm_camellia256_digest,
|
||||
--
|
||||
2.1.4
|
||||
|
Loading…
Reference in a new issue