Merge pull request #8354 from kenkeys/spoofer-v143

spoofer: Update to 1.4.3
This commit is contained in:
Hannu Nyman 2019-03-07 18:31:28 +02:00 committed by GitHub
commit b39e74324e
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
2 changed files with 4 additions and 17 deletions

View file

@ -1,5 +1,5 @@
#
# Copyright (C) 2018 The Regents of the University of California
# Copyright (C) 2019 The Regents of the University of California
#
# This is free software, licensed under the GNU General Public License v3.
# See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=spoofer
PKG_VERSION:=1.4.1
PKG_RELEASE:=2
PKG_VERSION:=1.4.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.caida.org/projects/spoofer/downloads
PKG_HASH:=e6d9e954709a15dc55187a962e8698d880f3df3ce8b914097c576a3a1f852d0d
PKG_HASH:=994555b360a095f0e9baed2469ef26bd29610af155ce58b3984d2f1616a74526
PKG_LICENSE:=GPL-3.0
PKG_LICENSE_FILES:=LICENSE

View file

@ -1,13 +0,0 @@
--- a/prober/spoofer-prober.cc
+++ b/prober/spoofer-prober.cc
@@ -2135,8 +2135,10 @@ int main(int argc, char **argv) {
#endif
#ifdef HAVE_LIBSSL
if (enableTLS) {
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
SSL_load_error_strings();
SSL_library_init();
+#endif
ssl_ctx = SSL_CTX_new(SSLv23_client_method());
if (!ssl_ctx) {
ssl_err("SSL_CTX_new() failed");